Bug 1067006 - PyKDE FTBFS against sip-4.15+
Summary: PyKDE FTBFS against sip-4.15+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PyKDE
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1105918 (view as bug list)
Depends On:
Blocks: F21FTBFS 1107055
TreeView+ depends on / blocked
 
Reported: 2014-02-19 13:56 UTC by Rex Dieter
Modified: 2014-09-23 04:41 UTC (History)
4 users (show)

Fixed In Version: PyKDE-3.16.7-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 04:41:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Rex Dieter 2014-02-19 13:56:48 UTC
subject says it all, PyKDE currently FTBFS against newer sip-4.15+ versions.  

Latest attempt,
http://koji.fedoraproject.org/koji/buildinfo?buildID=498560

kfile/sipkfileKFileIconView.cpp: In member function 'virtual KFile::SelectionMode sipKFileIconView::selectionMode() const':
kfile/sipkfileKFileIconView.cpp:683:16: error: reference to 'selectionMode' is ambiguous
In file included from /usr/include/kde/kfileiconview.h:30:0,
                 from sip/kfile/kfileiconview.sip:49:
/usr/include/kde/kfileview.h:219:34: note: candidates are: virtual KFile::SelectionMode KFileView::selectionMode() const
     virtual KFile::SelectionMode selectionMode() const;
                                  ^
In file included from /usr/include/kde/kiconview.h:22:0,
                 from /usr/include/kde/kfileiconview.h:28,
                 from sip/kfile/kfileiconview.sip:49:
/usr/lib/qt-3.3/include/qiconview.h:335:19: note:                 QIconView::SelectionMode QIconView::selectionMode() const
     SelectionMode selectionMode() const;
                   ^
kfile/sipkfileKFileIconView.cpp: In member function 'virtual void sipKFileIconView::clear()':
kfile/sipkfileKFileIconView.cpp:699:9: error: reference to 'clear' is ambiguous
In file included from /usr/include/kde/kfileiconview.h:30:0,
                 from sip/kfile/kfileiconview.sip:49:
/usr/include/kde/kfileview.h:146:18: note: candidates are: virtual void KFileView::clear()
     virtual void clear();
                  ^
In file included from /usr/include/kde/kiconview.h:22:0,
                 from /usr/include/kde/kfileiconview.h:28,
                 from sip/kfile/kfileiconview.sip:49:
/usr/lib/qt-3.3/include/qiconview.h:350:18: note:                 virtual void QIconView::clear()
     virtual void clear();

Comment 1 Rex Dieter 2014-02-19 13:57:35 UTC
giving this to Kevin, for now, I know he started working on this the other day.

Comment 2 Kevin Kofler 2014-02-19 14:23:25 UTC
Yeah, I applied a patch from openSUSE's KDE:KDE3 OBS repository to fix an earlier failure, but now we hit this, which they're also hitting. Now I'm trying to figure out how to best fix this. The cleanest fix would be to resolve the ambiguity in KFileIconView itself in kdelibs3, but the problem is that those methods are virtual, so overloading them has unwanted side effects.

Comment 3 Rex Dieter 2014-06-09 02:14:42 UTC
*** Bug 1105918 has been marked as a duplicate of this bug. ***

Comment 4 Kevin Kofler 2014-09-04 23:33:34 UTC
The openSUSE folks now came up with this hack:
https://build.opensuse.org/request/show/238556
that should fix the build. I'm trying this now, hoping that that will finally fix the issue.

(It's a sed hack that postprocesses the sip output. I already tried and failed to come up with a better fix, so I'll take the hack.)

Comment 5 Kevin Kofler 2014-09-04 23:40:37 UTC
Building PyKDE-3.16.7-4.fc22 in Rawhide now, we'll see how it goes. (I'll take care of F21 too if it succeeds in Rawhide.)

Comment 6 Kevin Kofler 2014-09-05 00:03:36 UTC
Looks like this is working, I also fired up the F21 build, will run it through Bodhi as soon as it completes.

Comment 7 Fedora Update System 2014-09-05 00:36:04 UTC
PyKDE-3.16.7-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/PyKDE-3.16.7-4.fc21

Comment 8 Fedora Update System 2014-09-06 00:58:54 UTC
Package PyKDE-3.16.7-4.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PyKDE-3.16.7-4.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10179/PyKDE-3.16.7-4.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-09-23 04:41:34 UTC
PyKDE-3.16.7-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.