Bug 106701 - Uppercase characters not allowed in passwd and group
Uppercase characters not allowed in passwd and group
Status: CLOSED DUPLICATE of bug 89677
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 14:32 EDT by Fernando Schapachnik
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Schapachnik 2003-10-09 14:32:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1) Gecko/20021203

Description of problem:
Uppercase characters are not allowed in /etc/passwd and /etc/group (more to the
point: they are rejected by {user,group}{add,mod}.

The problem lies in:

chkname.c:22 -> good_name

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.useradd JOE
    

Actual Results:  invalid user name 'JOE'

Expected Results:  Ok

Additional info:

Uppercase usernames/groups are needed for Samba.
Comment 1 Milan Kerslager 2003-10-23 00:45:36 EDT
Capital letters breaks at least sendmail, see other bugs for comments.

*** This bug has been marked as a duplicate of 89677 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.