Bug 1067096 - Adding new node running VDSM 4.14 will not add
Summary: Adding new node running VDSM 4.14 will not add
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Eli Mesika
QA Contact: bugs@ovirt.org
URL:
Whiteboard: infra
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-19 16:47 UTC by scott
Modified: 2014-04-22 06:50 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:25:33 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25077 0 None MERGED Adding config entry for VDSM 4.14 Never
oVirt gerrit 25421 0 None MERGED Adding config entry for VDSM 4.14 Never
oVirt gerrit 25422 0 None MERGED Adding config entry for VDSM 4.14 Never

Description scott 2014-02-19 16:47:04 UTC
Description of problem:
When adding a new node installed with ovirt-node-iso-3.0.4-1.0.201401291204.vdsm34.el6.iso
get the error:
Host is installed with VDSM version (4.14) and cannot join cluster which is compatible with VDSM versions [4.13, 4.9, 4.11, 4.12, 4.10].

Version-Release number of selected component (if applicable):
Engine 3.3

How reproducible:
Very

Steps to Reproduce:
1.  Run Engine 3.3 Compatibility level 3.2 or 3.3
2.  Add node
3.

Actual results:
Host is installed with VDSM version (4.14) and cannot join cluster which is compatible with VDSM versions [4.13, 4.9, 4.11, 4.12, 4.10].

Expected results:
To add to cluster

Additional info:

Comment 1 Itamar Heim 2014-02-23 08:28:54 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:20:12 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Dan Kenigsberg 2014-03-16 23:39:00 UTC
Eli, I believe that this bug should be solved in a more fundamental way: Vdsm 4.14 reported that it supports clusterLevel 3.2. It also had 3.3 in the list of its supportedEngines. This should have been enough for Engine-3.3 to accept it into a 3.2 cluster, even without explicit mentioning of the "4.14" string on Engine.

Comment 4 Eli Mesika 2014-03-18 12:08:30 UTC
(In reply to Dan Kenigsberg from comment #3)
> Eli, I believe that this bug should be solved in a more fundamental way:
> Vdsm 4.14 reported that it supports clusterLevel 3.2. It also had 3.3 in the
> list of its supportedEngines. This should have been enough for Engine-3.3 to
> accept it into a 3.2 cluster, even without explicit mentioning of the "4.14"
> string on Engine.

Please open a new BZ for that. Thanks

Comment 5 Sandro Bonazzola 2014-03-31 12:25:33 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.