Bug 1067194 - [GSS] (6.3.1) EJB3 client code swallows exceptions making it difficult to track down issues in production.
Summary: [GSS] (6.3.1) EJB3 client code swallows exceptions making it difficult to tra...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR1
: EAP 6.3.1
Assignee: baranowb
QA Contact: Jan Martiska
Russell Dickenson
URL:
Whiteboard:
Depends On: 1118892
Blocks: 1127593 eap631-blockers, eap631-payload, eap63-cp01-blockers 1104255
TreeView+ depends on / blocked
 
Reported: 2014-02-19 22:48 UTC by dstephan
Modified: 2018-12-06 15:55 UTC (History)
7 users (show)

Doc Type: Known Issue
Doc Text:
This release of JBoss EAP 6 carries a bug that causes EJB3 clients to swallow exceptions unless logging is set to DEBUG. This issue is expected to be resolved in a future release of the product.
Clone Of:
: 1118892 (view as bug list)
Environment:
Last Closed: 2014-10-13 18:38:08 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker EJBCLIENT-106 Major Resolved EJB3 client code swallows exceptions making it difficult to track down issues 2016-10-12 14:34:02 UTC

Description dstephan 2014-02-19 22:48:01 UTC
Description of problem:

Customer had great difficulty tracking down the root cause of the EJB client failure. It turned out to be a serialization exception.

The code in EJBInvocationHandler.sendRequestWithPossibleRetries swallows the exception in order to retry other nodes. However, with this serialization exception it was never going to work. 

The only way the customer could find the exception is to set DEBUG logging in production, which they find unacceptable.

Is it possible to return these exceptions up the stack to aid in troubleshooting?

Version-Release number of selected component (if applicable):
jboss-ejb-clien-1.0.21

Comment 2 baranowb 2014-08-08 06:39:54 UTC
PR merged: https://issues.jboss.org/browse/EJBCLIENT-106

Shifting to 'MODIFIED'

Comment 4 Jan Martiska 2014-08-28 10:58:06 UTC
Verified in EAP 6.3.1.CR1 / ejb client 1.0.26.Final


Note You need to log in before you can comment on or make changes to this bug.