Bug 10672 - HTTP to FTP switch during bootnet installation
HTTP to FTP switch during bootnet installation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-08 18:27 EDT by van der Kleut
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 17:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description van der Kleut 2000-04-08 18:27:08 EDT
When installing RedHat 6.2 from a floopy to which I rawwrite'd the Bootnet
image I encountered the following problem:

First setup:

new download Redhat 6.2 installed on running from webserver on Win 98
(HTTP).

Bootnet floppy on designated machine
Install method HTTP,
enter IP webserver
enter directory webserver where RH 6.2 resides.

after completing the above the installation does not conyinue because the
second stage can't be loaded.  Wrong response from FTP server, netsg2.img
can'tbe loaded is the response.
Comment 1 Anonymous 2000-04-14 09:40:59 EDT
I have found the same problem
Comment 2 Jay Turner 2000-04-24 11:09:59 EDT
The dialog titles "FTP Error" (or something like that) during a HTTP
installation is actually a bug.  The title on the dialog is incorrect and the
installer has not just changed installation methods :-)

Sounds like you are having a problem with the webserver you are installing
from.  If the netstg2.img file actually there (it should be in the /RedHat/base
directory), then I would make sure that you can get to it using a web browser.
If you are able to browse and see the file, then the HTTP installation should
work without any problems.
Comment 3 gotthard.saghi-szabo 2000-05-15 11:54:59 EDT
I am having the same problem. Here are the entries from my Apache log files:

error_log (when I try to run RH HTTP netinstall):
[Mon May 15 11:19:23 2000] [error] [client 10.1.2.1] Invalid URI in request GET
i386/RedHat/base/netstg2.img HTTP/0.9

access_log (when I successfully access the same file from lynx):
10.1.3.2 - - [15/May/2000:11:42:28 -0400] "GET /i386/RedHat/base/netstg2.img
HTTP/1.0" 200 2197746
Comment 4 van der Kleut 2000-05-18 17:11:59 EDT
In reply to jturner@redhat.com,
I tried your suggestion before I posted the bug, but the directory/file was
accessible thru a browser over my Intranet. I had previously distributed RH 6.1
succesfully under the same webdirectory structure and permissions and the same
webserver installation as the RH 6.2 install.
Comment 5 gotthard.saghi-szabo 2000-05-22 11:29:59 EDT
I think from my logfile entries the solution should be quite easy. It looks
like the HTTP installation agent in RH6.2 does not prepend a '/' in front of
the directory name automatically. I bet if you write e.g. "/i386" instead
of "i386" as the name of the directory containing the installation files, it
will work.
Comment 6 Michael Fulbright 2000-08-17 17:56:41 EDT
You are correct.

Note You need to log in before you can comment on or make changes to this bug.