Bug 1067249 - [virtio-win][balloon]Balloon device can not be removed after blnsrv service installed
Summary: [virtio-win][balloon]Balloon device can not be removed after blnsrv service i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1131838
TreeView+ depends on / blocked
 
Reported: 2014-02-20 02:27 UTC by Mike Cao
Modified: 2015-11-24 08:40 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 08:40:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (252.60 KB, image/png)
2014-02-20 02:27 UTC, Mike Cao
no flags Details
win2k8R2 unplug balloon device when balloon service running (104.30 KB, image/png)
2014-12-24 02:53 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Mike Cao 2014-02-20 02:27:07 UTC
Created attachment 865320 [details]
screenshot

Description of problem:


Version-Release number of selected component (if applicable):
# uname -r ;rpm -q qemu-kvm-rhev seabios
3.10.0-86.el7.x86_64
qemu-kvm-rhev-1.5.3-48.el7.x86_64
seabios-1.7.2.2-10.el7.x86_6

How reproducible:
100%

Steps to Reproduce:
1.start VM w/ virito-balloon-pci
CLI: /usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 2G -smp 4,cores=2,threads=1,sockets=2 -name bcao_win-7-32-netkvm -uuid aec324b5-51cb-4613-830c-c3341570e3f8 -rtc base=localtime,clock=host,driftfix=slew -drive file=win7-32.qcow2,if=none,media=disk,serial=aaabbbccc,werror=stop,rerror=stop,cache=none,format=qcow2,id=drive-disk0 -device ide-drive,physical_block_size=4096,bus=ide.0,unit=1,logical_block_size=512,drive=drive-disk0,id=disk0 -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso,if=none,media=cdrom,id=aa -device ide-drive,id=aa1,drive=aa,bootindex=1 -drive media=cdrom,if=none,id=bb -device ide-drive,id=bb1,drive=bb -netdev tap,vhost=on,id=netdev0 -device e1000,netdev=netdev0,id=nic1,mac=1a:46:11:4a:bc:7a -vnc :2 -monitor stdio -usb -device usb-tablet,id=tablet0 -global PIIX4_PM.disable_s3=0 -global PIIX_PM.disable_s4=0 -monitor unix:/tmp/tt,server,nowait -boot menu=on -device virtio-balloon-pci,id=balloon0 -qmp tcp:0:5888,server,nowait -global PIIX4_PM.disable_s4=0
2.install blnsrv.exe -i in the guest 
3.(qemu_device_del balloon0

Actual results:
balloon device can not be removed 

Expected results:
balloon device can be removed due to it is in use

Additional info:
not sure it is a bug ,open it first in case of missing bugs

Comment 2 RHEL Program Management 2014-03-22 05:59:36 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Gal Hammer 2014-07-06 07:44:37 UTC
What is the balloon driver's version?

Comment 7 Mike Cao 2014-07-21 06:21:36 UTC
Reproduce this issue on virtio-win-prehql-80 
Verified this issue on virtio-win-prewhql-87

Steps same as comment #0

Actual Results:
on build80 ,the device can not be deleted 
on build 87,the device can be deleted successfully

Based on above ,this issue has been fixed ald 
Move status to Verified

Comment 8 lijin 2014-12-24 02:53:54 UTC
Created attachment 972619 [details]
win2k8R2 unplug balloon device when balloon service running

win2k8R2 guest still hit this issue,balloon device cannot be unplug while balloon service running(show as the attachment);
win8-32 does not hit this issue,balloon device can be hot-unplug correctly.

package info:
virtio-win-prewhql-96
qemu-kvm-rhev-2.1.2-12.el7.x86_64
kernel-3.10.0-208.el7.x86_64
seabios-bin-1.7.5-5.el7.noarch
spice-server-0.12.4-8.el7.x86_64

Comment 9 lijin 2014-12-24 03:13:26 UTC
win7-64 guest also hit this issue
change status to ASSIGNED

Comment 10 lijin 2014-12-26 07:21:52 UTC
retry with build87,win2k8R2 and win7-64 can unplug device correctly when balloon service running.

Comment 11 Gal Hammer 2014-12-28 09:58:44 UTC
Caused by a change to the service's display name. A patch was posted.

Comment 12 lijin 2015-01-04 03:22:07 UTC
can reproduce this issue with virtio-win-1.7.2-2.el6

Comment 17 Mike Cao 2015-03-30 06:09:53 UTC
Retest this issue on virtio-win-prewhql-102

Steps same as comment #0

Tried on win7-32 guest ,
Actual Results :balloon device can be removed when blnsrv in running status

Tried on win2k8R2 guest 
Actual Results :balloon device can not be removed when blnsrv in running status,same as comment#12


Based on above ,this issue hasn't been fixed yet.

reassign this isue.

Comment 19 Gal Hammer 2015-04-15 13:11:03 UTC
(In reply to Mike Cao from comment #17)
> Retest this issue on virtio-win-prewhql-102
> 
> Steps same as comment #0
> 
> Tried on win7-32 guest ,
> Actual Results :balloon device can be removed when blnsrv in running status
> 
> Tried on win2k8R2 guest 
> Actual Results :balloon device can not be removed when blnsrv in running
> status,same as comment#12

I'm unable to reproduce on Windows 2008 R2. What is the "Service name" and "Display name" of the balloon's service?
 
> Based on above ,this issue hasn't been fixed yet.
> 
> reassign this isue.

Comment 20 Mike Cao 2015-04-22 10:55:44 UTC
(In reply to Gal Hammer from comment #19)
> (In reply to Mike Cao from comment #17)
> > Retest this issue on virtio-win-prewhql-102
> > 
> > Steps same as comment #0
> > 
> > Tried on win7-32 guest ,
> > Actual Results :balloon device can be removed when blnsrv in running status
> > 
> > Tried on win2k8R2 guest 
> > Actual Results :balloon device can not be removed when blnsrv in running
> > status,same as comment#12
> 
> I'm unable to reproduce on Windows 2008 R2. What is the "Service name" and
> "Display name" of the balloon's service?

Sorry for the late response.

Service name: BalloonService
Display name: Balloon Service

Comment 21 Gal Hammer 2015-04-26 10:34:32 UTC
(In reply to Mike Cao from comment #20)
> (In reply to Gal Hammer from comment #19)
> > (In reply to Mike Cao from comment #17)
> > > Retest this issue on virtio-win-prewhql-102
> > > 
> > > Steps same as comment #0
> > > 
> > > Tried on win7-32 guest ,
> > > Actual Results :balloon device can be removed when blnsrv in running status
> > > 
> > > Tried on win2k8R2 guest 
> > > Actual Results :balloon device can not be removed when blnsrv in running
> > > status,same as comment#12
> > 
> > I'm unable to reproduce on Windows 2008 R2. What is the "Service name" and
> > "Display name" of the balloon's service?
> 
> Sorry for the late response.
> 
> Service name: BalloonService
> Display name: Balloon Service

This looks okay. Does it reproduce on a new installed of Windows and balloon service?

Comment 22 Mike Cao 2015-04-27 07:05:34 UTC
(In reply to Gal Hammer from comment #21)
> (In reply to Mike Cao from comment #20)
> > (In reply to Gal Hammer from comment #19)
> > > (In reply to Mike Cao from comment #17)
> > > > Retest this issue on virtio-win-prewhql-102
> > > > 
> > > > Steps same as comment #0
> > > > 
> > > > Tried on win7-32 guest ,
> > > > Actual Results :balloon device can be removed when blnsrv in running status
> > > > 
> > > > Tried on win2k8R2 guest 
> > > > Actual Results :balloon device can not be removed when blnsrv in running
> > > > status,same as comment#12
> > > 
> > > I'm unable to reproduce on Windows 2008 R2. What is the "Service name" and
> > > "Display name" of the balloon's service?
> > 
> > Sorry for the late response.
> > 
> > Service name: BalloonService
> > Display name: Balloon Service
> 
> This looks okay. Does it reproduce on a new installed of Windows and balloon
> service?
Yes ,on virtio-win-prewhql-103

Comment 23 Gal Hammer 2015-05-03 13:55:44 UTC
Disabling a device and a device surprise removal are not the same.

A patch was posted.

Comment 24 Vadim Rozenfeld 2015-05-24 06:23:18 UTC
please check with the latest build available at
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/104/win/virtio-win-prewhql-0.1.zip

Comment 25 lijin 2015-06-01 05:05:07 UTC
mdeng,please verify this bug with build104

Comment 26 Min Deng 2015-06-03 07:18:50 UTC
  Retest the bug with build104 on win2k8-R2 and now the balloon device could be removed successfully without any error.
  So the issue has been fixed on build 104,thanks!

Comment 27 Min Deng 2015-06-03 08:36:16 UTC
(In reply to dengmin from comment #26)
>   Retest the bug with build104 on win2k8-R2 and now the balloon device could
> be removed successfully without any error.
>   So the issue has been fixed on build 104,thanks!

  Also QE can reproduce the issue on old build 98.Thanks.
  Retest the bug with build104 on win2k8-R2 and now the balloon device could be removed successfully without any error.
  So the issue has been fixed on build 104,thanks!

Comment 28 Jeff Nelson 2015-06-04 14:27:47 UTC
Min,

According to comments 26 and 27 the problem is solved. If so, shouldn't the BZ status be VERIFIED? Please correct me if I am mistaken. Thanks.

Comment 29 lijin 2015-06-05 02:23:36 UTC
change status to verified according to comment#26 and comment#27

Comment 33 errata-xmlrpc 2015-11-24 08:40:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.