Bug 1067355 - Failed to register to satellite 6 via TUI
Summary: Failed to register to satellite 6 via TUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1 1174626
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-02-20 10:19 UTC by cshao
Modified: 2019-04-24 14:05 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Previously, an incorrect call from the Hypervisor TUI to Subscription Manager was preventing the Hypervisor from attaching to the Satellite 6 server. This call has now been rewritten and the TUI can be used to subscribe the Hypervisor to the Satellite server as expected.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:53:24 UTC
oVirt Team: Node


Attachments (Terms of Use)
ovirt.log (77.51 KB, text/plain)
2014-02-20 10:21 UTC, cshao
no flags Details
rhsm.log (223.87 KB, text/plain)
2014-02-20 10:22 UTC, cshao
no flags Details
new-ovirt-node.log (25.29 KB, text/plain)
2014-10-29 10:16 UTC, cshao
no flags Details
Jan-28-satellite6.tar.gz (6.06 MB, application/x-gzip)
2015-01-28 11:16 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 30282 None None None Never
oVirt gerrit 34909 None None None Never
oVirt gerrit 34941 master MERGED Make rhn_model work with Satellite 6 Never
oVirt gerrit 36620 ovirt-3.5 MERGED Make rhn_model work with Satellite 6 Never

Comment 1 cshao 2014-02-20 10:21:31 UTC
Created attachment 865405 [details]
ovirt.log

Comment 2 cshao 2014-02-20 10:22:58 UTC
Created attachment 865406 [details]
rhsm.log

Comment 5 Fabian Deutsch 2014-02-21 08:18:39 UTC
To me it looks like we should be using subscription-manager for SAM, instead of rhn_reg.

Comment 6 haiyang,dong 2014-02-21 08:29:15 UTC
(In reply to Fabian Deutsch from comment #5)
> To me it looks like we should be using subscription-manager for SAM, instead
> of rhn_reg.

it should be  using subscription-manager for Satellite, instead of rhn_reg.

Comment 7 cshao 2014-02-21 08:34:38 UTC
(In reply to Fabian Deutsch from comment #5)
> To me it looks like we should be using subscription-manager for SAM, instead
> of rhn_reg.

Agree with you :)

Please refer satellite 6 User Guide for manual & automated Configuration.

https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/Manual_Configuration.html

Thanks!

Comment 8 cshao 2014-02-21 08:42:49 UTC
(In reply to shaochen from comment #7)
> (In reply to Fabian Deutsch from comment #5)
> > To me it looks like we should be using subscription-manager for SAM, instead
> > of rhn_reg.
> 
> Agree with you :)
> 
> Please refer satellite 6 User Guide for manual & automated Configuration.
> 
> https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/6.0/
> html/User_Guide/Manual_Configuration.html
> 
> Thanks!

aha, it is typo, it should be using subscription-manager for Satellite but not sam.

Comment 11 Fabian Deutsch 2014-02-25 12:38:16 UTC
Yes, I agree.

We should offer distinct options for the different server sides.

Maybe we can split it up:

( ) RHN    ( ) SAM
( ) Satellite   ( ) Satellite >= 6.0

 URL: _______

The URL field could then only be enabled when Satellite is chosen. Then we don't have to do the whole logic about when which URL has to be used.

RHN and SAM would be Red Hat's services.

Satellite and Satellite >= 6.0 would be the custom instances setup by customers.

Does that make sense?

Comment 19 Ying Cui 2014-07-18 07:06:27 UTC
I would like to up this bug priority to 'Urgent', due to satellite 6 is released on 2013, we need to support it asap.

Comment 20 akotov 2014-10-09 08:58:19 UTC
How i imagined it - no need to add additional Sat6 option in TUI. May be let's try XMLRPC-rhn_regks first, if it fails, we go to new Sat6 URL/subscription-manager method, and only if it fails too, we display error to the user.

Comment 22 cshao 2014-10-29 10:16:27 UTC
Created attachment 951730 [details]
new-ovirt-node.log

Comment 27 Ryan Barry 2014-11-06 19:15:43 UTC
bkearney:

I have a question about /etc/rhsm/rhsm.conf...

When registering to Satellite6, we set rhsm.baseurl=http://sat6.server.../pulp/repos

However, trying to register with subscription-manager fails unless we also set server.prefix to /rhsm. Is this expected behavior? There are two questions:

First is that server.prefix is set to /subscription out of the box. It's counterintuitive to need to change it as long as we've set rhsm.baseurl. Is this expected behavior?

Second, is there a way to programmatically determine what server.prefix should be? Can we rely on it always being rhsm, or do we need to try to parse longer URLs according to some scheme?

Comment 28 Ying Cui 2014-11-07 15:10:14 UTC
this issue still can reproduce in rhevh 6.6 for RHEV 3.4.z bulid version:
rhev-hypervisor6-6.6-20141106.1.iso
ovirt-node-3.0.1-19.el6.22

Comment 29 Bryan Kearney 2014-11-07 22:51:38 UTC
Ryan:

It is possible for the content to come from a different location that the subscriptions, which is why you see two settings.

If you look in the /pub directory of the satellite.. you will see an rpm which will configure subscription manager for you. Is it possible to use that?

-- bk

Comment 30 Ryan Barry 2014-11-07 23:41:15 UTC
Bryan -

Short answer is no. The RHEV-H image is read-only. We can't install an RPM.

Is there documentation somewhere for what we can expect to see in each instance?

Comment 31 cshao 2014-11-11 02:59:25 UTC
This issue still can reproduce in rhevh 7.0 for RHEV 3.5 
(rhev-hypervisor7-7.0-20141107.0)
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch

Comment 32 Ryan Barry 2014-11-11 04:18:52 UTC
The upstream patch is not merged.

Comment 33 Ryan Barry 2014-11-24 15:43:38 UTC
(In reply to Ryan Barry from comment #30)
> Bryan -
> 
> Short answer is no. The RHEV-H image is read-only. We can't install an RPM.
> 
> Is there documentation somewhere for what we can expect to see in each
> instance?

Bryan, any advice?

Comment 34 Julie 2014-11-26 08:54:16 UTC
Doc text added as per engineering request for Beta 5 release. Please update the text for GA or simply set the 'requires_release_notes' flag to - and the text will be excluded from the GA release notes. If you do not change the flag, the same text will appear in GA release notes.

Comment 38 Ryan Barry 2014-12-18 18:27:56 UTC
One of the dependent patches was not merged, which also caused bz#1174626

Comment 39 Fabian Deutsch 2015-01-12 08:47:50 UTC
To my understanding everything has been merged, including the dependency in bug 1174626.

Comment 41 cshao 2015-01-28 11:16:11 UTC
Created attachment 985098 [details]
Jan-28-satellite6.tar.gz

Comment 45 Ying Cui 2015-01-29 05:38:10 UTC
For me, checked QE satellite 6 env.(10.66.72.162) the 'test' org is broken on server

Error
Katello::Resources::Candlepin::CandlepinResource: 404 Resource Not Found {"displayMessage":"Organization with id test could not be found.","requestUuid":"df595b99-40a8-496e-bc05-3a2576d11c8b"} (GET /candlepin/owners/test/servicelevels)

_rhevh_ org in satellite 6 already and I created new org name "TestNewOrg" for this bug verification if need.

Comment 46 Ying Cui 2015-01-29 06:05:15 UTC
> _rhevh_ org in satellite 6 already and I created new org name "TestNewOrg"
> for this bug verification if need.

Please use rhevh org for testing.
s1satellite6.rhevm.englab.nay.redhat.com this host had been added into rhevh org already.

and so far no host to new TestNewOrg. so it can be ignored.

Comment 47 haiyang,dong 2015-01-29 06:18:17 UTC
Test version:
rhev-hypervisor7-7.0-20150127.0.iso
ovirt-node-3.2.1-6.el7.noarch

rhev-hypervisor6-6.6-20150128.0.iso
ovirt-node-3.2.1-6.el6.noarch

Test steps:
1. Install RHEV-H.
2. Register to satellite 6 via TUI.
Login:    admin
Password: redhat
Type       ( ) RHN          (X) Satellite    ( ) SAM 
RUL: https://s1satellite6.rhevm.englab.nay.redhat.com
CA URL: http://s1satellite6.rhevm.englab.nay.redhat.com/pub/candlepin-local.pem
Organization: rhevh

Test result:
These two version iso register to satellite 6 via TUI success.

success log info in /var/log/ovirt-node.log
----------------------
2015-01-29 05:57:01,172       INFO Downloading CA cert.....
2015-01-29 05:57:01,187       INFO File "/etc/rhsm/ca/candlepin-local.pem" successfully persisted
2015-01-29 05:57:01,984       INFO File "/etc/rhsm/rhsm.conf" successfully persisted
2015-01-29 05:57:01,986       INFO Registering to RHN account.....
2015-01-29 05:57:01,989       INFO ['/usr/sbin/subscription-manager', 'register', '--username', 'admin', '--password', 'XXXXXXX', '--org', 'rhevh', '--force']
2015-01-29 06:08:45,997    WARNING File "/etc/pki/consumer/key.pem" had already been persisted
2015-01-29 06:08:45,999    WARNING File "/etc/pki/consumer/cert.pem" had already been persisted
2015-01-29 06:08:45,999       INFO System None sucessfully registered                                       to https://s1satellite6.rhevm.englab.nay.redhat.com
2015-01-29 06:08:45,999       INFO Captured nothing
2015-01-29 06:08:46,106       INFO Changes were merged successfully

so this bug has been fixed, changed the status into "VERIFIED".

Comment 49 errata-xmlrpc 2015-02-11 20:53:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.