Bug 1067470 - FTBFS: testsuite fails on big endians
FTBFS: testsuite fails on big endians
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2014-02-20 08:58 EST by Karsten Hopp
Modified: 2016-01-22 09:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 09:57:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log of the failing tests (812 bytes, text/plain)
2014-02-20 08:58 EST, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2014-02-20 08:58:09 EST
Created attachment 865530 [details]
Log of the failing tests

Description of problem:
FAIL: mix-test
FAIL: once-test


============================================================================
Testsuite summary for pulseaudio 4.99.4
============================================================================
# TOTAL: 30
# PASS:  28
# SKIP:  0
# XFAIL: 0
# FAIL:  2
# XPASS: 0
# ERROR: 0
============================================================================
See src/test-suite.log

Version-Release number of selected component (if applicable):
pulseaudio-4.99.4-2.fc21

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f21 pulseaudio-4.99.4-2.fc21.src.rpm
2.
3.

Actual results:


Expected results:


Additional info:
reproducable on my PowerPc here, it's not a koji issue.
If you need access to a PPC machine, please send me your public ssh key and I'll give you an account with mock group.
Comment 1 Dan Horák 2014-05-13 05:16:00 EDT
builds on s390/s390x fail due the mix-test
Comment 3 Rex Dieter 2014-10-22 10:17:19 EDT
boo, just tested a pulseaudio snapshot, and seeing one failure on ppc64 still:

FAIL: once-test

scratch build:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2154576
Comment 4 Jaroslav Reznik 2015-03-03 10:30:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 5 Rafael Fonseca 2015-08-13 08:31:48 EDT
pulseaudio seems to be built successfully for ppc. Can we close this bug?
Comment 6 Rex Dieter 2015-08-13 08:37:42 EDT
IMO, best to close this only after confirming 100% successful test suite coverage.

Currently. pulseaudio.spec still ignores test-suite errors on some platforms referenced in this bug:

%check
# don't fail build due failing tests on big endian arches (rhbz#1067470)
make check \
%ifarch ppc %{power64} s390 s390x
  || :
%else
  %{nil}
%endif


Looking at recent log,
http://ppc.koji.fedoraproject.org/kojifiles/packages/pulseaudio/6.0/8.fc23/data/logs/ppc64/build.log

...
FAIL: once-test
...
============================================================================
Testsuite summary for pulseaudio 6.0
============================================================================
# TOTAL: 33
# PASS:  32
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See src/test-suite.log
Please report to pulseaudio-discuss (at) lists (dot) freedesktop (dot) org
============================================================================
Makefile:10353: recipe for target 'test-suite.log' failed
Comment 7 Rafael Fonseca 2015-08-13 08:56:26 EDT
I'm only seeing the failure on f23/ppc64; f22/ppc64, f22/ppc64le, and f23/ppc64le work fine.
Comment 8 Rex Dieter 2015-08-13 09:09:55 EDT
Hint: ppc64le isn't big endian  :)
Comment 9 Rex Dieter 2015-08-13 09:11:28 EDT
oh, I misread your comment.  so f22/ppc64 doesn't see the error?  lemme verify in build logs.
Comment 10 Rex Dieter 2015-08-13 09:12:37 EDT
confirmed,
http://ppc.koji.fedoraproject.org/kojifiles/packages/pulseaudio/6.0/4.fc22/data/logs/ppc64/build.log

============================================================================
Testsuite summary for pulseaudio 6.0
============================================================================
# TOTAL: 33
# PASS:  33
# SKIP:  0
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0


interesting (and frustrating!) :)
Comment 11 Rafael Fonseca 2015-08-13 09:34:11 EDT
Just checked on s390, and the tests pass on both s390 [1] and s390x [2]. So the issue is specific to f23/ppc64. I'll try to reproduce it there and gather more information.

[1] http://s390.koji.fedoraproject.org/kojifiles/packages/pulseaudio/6.0/8.fc23/data/logs/s390/build.log
[2] http://s390.koji.fedoraproject.org/kojifiles/packages/pulseaudio/6.0/8.fc23/data/logs/s390x/build.log
Comment 12 Rafael Fonseca 2015-08-13 10:53:14 EDT
Building pulseaudio locally on a ppc64 guest succeeds:

============================================================================
Testsuite summary for pulseaudio 6.0
============================================================================
# TOTAL: 33
# PASS:  33
# SKIP:  0
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0
============================================================================

And it fails on ppc-koji scratch build [1]:

FAIL: once-test
[..]
============================================================================
Testsuite summary for pulseaudio 6.0
============================================================================
# TOTAL: 33
# PASS:  32
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================

I'm confused now. Maybe it's a koji-only issue on f23?

[1] http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/2971/2702971/build.log
Comment 13 Rafael Fonseca 2015-08-14 10:14:31 EDT
The issue happens only on ppc-koji builder with kernel 3.14.5-200.fc20.ppc64p7. It's probably because of old kernel vs glibc. The failure log is:

========================================
   pulseaudio 6.0: src/test-suite.log
========================================

# TOTAL: 33
# PASS:  32
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: once-test
===============

Running suite(s): Once
0%: Checks: 1, Failures: 1, Errors: 0
tests/once-test.c:74:F:once:once_test:0: Assertion 'pthread_setaffinity_np(pthread_self(), sizeof(mask), &mask) == 0' failed
Comment 14 Rex Dieter 2016-01-22 09:57:25 EST
Looks like recent builds are succeeding,

http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=365268

Note You need to log in before you can comment on or make changes to this bug.