Bug 1067548 - [DWH-SETUP][TEXT] - misconfiguartion of remote DB setup
Summary: [DWH-SETUP][TEXT] - misconfiguartion of remote DB setup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-20 15:58 UTC by Barak Dagan
Modified: 2014-12-08 15:59 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-3.4.0_rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:31:47 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1077825 0 unspecified CLOSED [RHEVM-SETUP][TEXT] - typo in configuartion of remote DB setup 2021-02-22 00:41:40 UTC
oVirt gerrit 25510 0 None None None Never
oVirt gerrit 25511 0 None MERGED packaging: setup: database: align manual instructions with defaults Never
oVirt gerrit 25513 0 None None None Never
oVirt gerrit 25515 0 None MERGED packaging: setup: database: align manual instructions with defaults Never
oVirt gerrit 25516 0 None MERGED packaging: setup: database: align manual instructions with defaults Never
oVirt gerrit 25867 0 None None None Never
oVirt gerrit 25868 0 None None None Never
oVirt gerrit 25869 0 None MERGED packaging: setup: database: fix typo in manual instructions Never
oVirt gerrit 25870 0 None MERGED packaging: setup: database: fix typo in manual instructions Never
oVirt gerrit 25871 0 None MERGED packaging: setup: database: fix typo in manual instructions Never
oVirt gerrit 25886 0 None MERGED packaging: setup: database: fix typo in manual instructions Never
oVirt gerrit 25887 0 None MERGED packaging: setup: database: fix typo in manual instructions Never
oVirt gerrit 25888 0 None MERGED packaging: setup: database: fix typo in manual instructions Never

Internal Links: 1077825

Description Barak Dagan 2014-02-20 15:58:59 UTC
Description of problem:

During installation, there are instruction for manual action over the remote server:

          Please create database for ovirt-engine-dwh use. Use the following commands as an example:
         
          create role engine_history with login encrypted password 'engine_history';create database engine_history owner engine_history template template0
          encoding 'UTF8' lc_collate 'en_US.UTF-8'
          lc_ctype 'en_US.UTF-8';


During the setup, the defaults are different:
          DWH database host [localhost]: my.remote.server.redhat.com
          DWH database port [5432]: 
          DWH database secured connection (Yes, No) [No]: 
          DWH database name [ovirt_engine_history]: 
          DWH database user [ovirt_engine_history]: engine_history
          DWH database password: 
[ ERROR ] Cannot connect to DWH database: Cannot connect to database: FATAL:  database "ovirt_engine_history" does not exist 


Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.11.beta3.el6.noarch
ovirt-engine-dwh-setup-3.4.0-0.3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. install dwh over remote db server
2. 
3.

Actual results:
1) The instructions are not indented correctly
2) In the instruction the role, db & passwrod are engine_history
3) The defult answer for role & db are ovirt_engine_history
4) In previous version the role & password were selected by the user. If this is the case here, please fix the instruction, if the names are fixed, why asking for them ?

Expected results:


Additional info:

Comment 1 Itamar Heim 2014-02-23 08:28:29 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:29:15 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Sandro Bonazzola 2014-03-06 11:06:47 UTC
Maybe this is worth to be fixed in 3.4.0. It seems a low risk one and avoid headache trying to figure out why remote db connection fails...

Comment 4 Alon Bar-Lev 2014-03-07 08:06:11 UTC
Why there is no log attached?

Why trivial issues are not handled at same day issue is found?

Comment 5 Alon Bar-Lev 2014-03-07 08:27:31 UTC
Moving to core product to fix all satellite packages.

Comment 6 Barak Dagan 2014-03-18 16:25:25 UTC
verification failed on av3:

create ovirt_engine_history engine owner ovirt_engine_history <= ?????
template template0
encoding 'UTF8' lc_collate 'en_US.UTF-8'
lc_ctype 'en_US.UTF-8';

Comment 7 Alon Bar-Lev 2014-03-18 18:52:08 UTC
(In reply to Barak Dagan from comment #6)
> verification failed on av3:
> 
> create ovirt_engine_history engine owner ovirt_engine_history <= ?????
> template template0
> encoding 'UTF8' lc_collate 'en_US.UTF-8'
> lc_ctype 'en_US.UTF-8';

Nice!!! :)

/me cannot read.

Comment 8 Sandro Bonazzola 2014-03-20 14:36:13 UTC
looks like all patches have been merged, anything else left?

Comment 9 Alon Bar-Lev 2014-03-20 14:44:17 UTC
(In reply to Sandro Bonazzola from comment #8)
> looks like all patches have been merged, anything else left?

I truly hope so.

Comment 10 Sandro Bonazzola 2014-03-31 12:31:47 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Comment 11 dariusz 2014-12-08 15:59:53 UTC
Finally, everything works fine.
Full reinstallation DWH and Reports engine has resolved problem.
Problem has been occured because description from the ovirt website 
(http://www.ovirt.org/Ovirt_Reports)
is not consequent.
As I understand installation procedure for 3.5 version doesn't require additional installation of the DWH package. I was wrong. It is.


Note You need to log in before you can comment on or make changes to this bug.