Bug 10676 - Failing to find a DHCP server results in boot "hang"
Failing to find a DHCP server results in boot "hang"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-09 01:46 EDT by j6000
Modified: 2007-04-18 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 14:43:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j6000 2000-04-09 01:46:23 EDT
When setting up /etc/sysconfig/network-scripts/ifcfg-eth0 so that it has
BOOTPROTO=dhcp causes redhat to effectivly "hang" if you cannot find a
DHCP server on boot time.

Senario:

1. Setup eth0 to obtain an IP via DHCP.
2. Reboot the system w/ network cord pulled from the NIC card.
3. System boots and says "Bringing up eth0...."
4. Waiting for 20 minutes and the system is still waiting to bring up eth0

I am not sure if this should time out after "some" period of time, but it
would be much friendlier if it was quicker.

Thanks,

Derrick
Comment 1 Brock Organ 2000-04-11 09:26:59 EDT
I cannot reproduce this behavior for a random machine, the ifup eth0 times out at one minute:
(from /var/log/messages):
Apr 11 07:24:36 localhost network: Setting network parameters succeeded
Apr 11 07:24:36 localhost network: Bringing up interface lo succeeded
Apr 11 07:24:37 localhost ifup: Determining IP information for eth0...
Apr 11 07:24:37 localhost pumpd[267]: starting at (uptime 0 days, 0:00:32) Tue Apr 11 07:24:37 2000
Apr 11 07:25:37 localhost ifup: Operation failed.
Apr 11 07:25:37 localhost ifup:  failed.
Apr 11 07:25:37 localhost network: Bringing up interface eth0 failed

note the time between ifup starting and failing is one minute ...

what NIC are you using...?
Comment 2 Glen Foster 2000-07-31 14:31:46 EDT
Re-assigning to component "pump" at the request of the QA department...
Comment 3 Need Real Name 2001-03-15 21:01:01 EST
I get the same thing, but with Redhat 7 (fresh install).  If I disconnect the 
network cable pump crashes the machine when it cannot find DHCP, after 
approximately 30 seconds.  I disabled auto-start of the network card, and ran 
pump manually both with and without the cable present.  With cable, no 
problem.  Without cable, hangs after 30 seconds - can't ctrl-alt-delete, can't 
switch between virtual terminals; can only do a hardware reset.

My network card is a 3Com Etherlink 10/100 PCI 3C905C-TX-M.

Other hardware: ABit VP6 motherboard (with onboard IDE RAID controller and dual 
processor capable, but neither of these goodies in use), ATI Xpert 98 video 
card, single 866MHz Pentium III, 256MB RAM, dual 40GB Quantum IDE hard drives 
(though I'm not using these in RAID - yet ;-).  1 floppy, 1 IDE CD.
Comment 4 Elliot Lee 2001-08-26 17:26:24 EDT
Ancient bug, sorry for the unresponsiveness of the previous pump packager...

WRT the hard lock experienced by jsantab, can you please file a separate bug
against the kernel if you still experience this problem?

The very long timeout problem sounds like it does not occur any more - can
someone verify this please, against RHL 7.1 or Roswell?
Comment 5 Jay Turner 2003-04-14 14:43:52 EDT
Closing out due to age of bug.

Note You need to log in before you can comment on or make changes to this bug.