Bug 106795 - Apache 2.0.4X with mod_ssl hangs on startup
Apache 2.0.4X with mod_ssl hangs on startup
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mod_ssl (Show other bugs)
2.1
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
http://nagoya.apache.org/bugzilla/sho...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 13:23 EDT by Mike Osterman
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 09:03:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Osterman 2003-10-10 13:23:03 EDT
Description of problem:

Since upgrading to Apache 2.0.4x from 1.3.x, I am no longer able to enter the 
PEM pass phrase during the boot process. Since I can sshd at that point, I can 
see that the process has started and that it has sent the login prompt 
*somewhere*, just not where it should be. I was told by Apache that I should 
report the bug to you. Here are the symptoms.

1. It DOES prompt for the PEM passphrase once the system is fully loaded and I 
am logged into the bash shell either at the console or via an SSH session.

2. It DOES NOT prompt for the passphrase during startup at console where it 
used to on 1.3.x. It goes through all the motions, and displays "Starting 
httpd.....", but the passphrase prompt does not appear as it should. Ignoring 
its absence, typing the PEM passphrase and sending a carriage return does not 
fix it. The machine simply does not continue to boot, as there is never 
a "succeeded" for httpd in the boot script display. My guess is that whatever 
is generating the script is not directing it to prompt for the PEM passphrase 
via STDIN. 

Note: This has been replicated on several different Dell PowerEdge servers 
(just in case hardware is somehow an issue?) on RedHat Enterprise Linux WS 
2.1, RedHat 7.3, and RedHat 9.0.


Version-Release number of selected component (if applicable):

httpd 2.0.47 (source installation)

How reproducible:

Every Time.

Steps to Reproduce:
1. Install httpd 2.0.4x from source with mod_ssl support:
   ./configure \
--prefix=/usr/local/apache \
--enable-so \
--enable-rewrite \
--enable-info \
--enable-status \
--enable-speling \
--enable-ssl \
--enable-cgi \
--enable-auth \
--enable-dir \
--enable-userdir \
--enable-mime-magic \
--enable-mime \
--enable-suexec \
--with-suexec-caller=apache \
--with-suexec-userdir=. \
--with-suexec-docroot=/export/htdocs \
--enable-proxy \
--enable-proxy-http \
--enable-cache \
--enable-disk-cache \
--disable-ipv6

2. Set up the private key to require the PEM passphrase.
3. Use the private key to generate a cert request and install an SSL cert.
4. Reboot.
5. Try to get past the "Starting httpd..." screen on the console.
    
Actual results:

Boot process gets stuck while trying to start httpd. No PEM passphrase prompt 
provided.

Expected results:

I should be prompted for the PEM passphrase at the console.

Additional info:

Am using RPM of openssl.
Comment 1 Joe Orton 2003-10-10 17:54:36 EDT
Can you reproduce this using the httpd-2.0.40 package included in Red Hat Linux 9?

If you are using a self-compiled httpd from a source tarball, the bug at
apache.org was the appropriate place to report it.
Comment 2 Joe Orton 2003-11-11 09:03:22 EST
I can't reproduce this in the 2.0.46-based packages included in RHEL3.
 2.0 is not supported by Red Hat on RHEL2.1, so this bug is not valid
here.

Note You need to log in before you can comment on or make changes to this bug.