Bug 106830 - ddcprobe fails
ddcprobe fails
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-11 03:56 EDT by Daniel Malmgren
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 14:07:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2003-10-11 03:56:25 EDT
Description of problem:
I'm not really sure what the command ddcprobe is supposed to return, but it just
fails in my case.

Version-Release number of selected component (if applicable):
rhpl-0.117-1

How reproducible:
always

Steps to Reproduce:
1. start the program
    
Actual results:
[root@Datorn rpm]# ddcprobe
 
Videocard DDC probe results
Description:  NVidia Corporation NV11 (GeForce2) Board
Memory (MB):  32
 
Monitor DDC probe results
Monitor DDC Probe failed.

Expected results:
Not quite sure ;-)

Additional info:
I'm using nvidias latest drivers for my GForce2 card.
This makes my redhat-config-xfree86 fail to start too. I get the following from it:

[root@Datorn rpm]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 350, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 143, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 272, in
init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 50, in
compare_resolution
    a1 = resolution_area(res1)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 46, in
resolution_area
    (w, h) = resolution_from_string(res)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 42, in
resolution_from_string
    (w, h) = string.split (res, "x")
ValueError: unpack list of wrong size
Comment 1 Jeremy Katz 2003-10-13 17:25:47 EDT
DDC doesn't always work (depends on a variety of bios, video bios and monitor),
so redhat-config-xfree86 should also handle the case where it can't be used.
Comment 2 Brent Fox 2003-10-14 12:57:53 EDT
Jeremy, I agree that redhat-config-xfree86 needs to handle the case when the
ddcprobe doesn't work, but in this case it appears the bug is in xhwstate.py in
rhpl since it's trying to split an empty string.  Shouldn't it return some kind
of error in this case instead of tracebacking?
Comment 3 Brent Fox 2004-01-16 19:11:55 EST
jeremy: ping?
Comment 4 Brent Fox 2004-02-19 21:25:09 EST
As root, try this:
kudzu --probe --bus=DDC

What is the output of that?
Comment 5 Brent Fox 2004-03-17 14:07:05 EST
Closing due to lack of information.  Please reopen if you can provide
more data.

Note You need to log in before you can comment on or make changes to this bug.