Bug 106833 - init script restart does not often work
init script restart does not often work
Status: CLOSED DUPLICATE of bug 58732
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-11 07:58 EDT by Emmanuel Galanos
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2003-10-11 07:58:03 EDT
Description of problem:
The Red Hat MySQL initscript stop part does:
     /bin/kill `cat /var/run/mysqld/mysqld.pid

then continues on its merry way not waiting for the server to shutdown before
returning. If this followed rapidly by a start (ie restart was called), then
mysql does not start as the previous server has not completed the shutdown.

Version-Release number of selected component (if applicable):
mysql-3.23.58-1.9 (also on RHL 8 & 7.3 affected)

How reproducible:
Most of our MySQL servers did not come back up after recent upgrades via RHN.

Steps to Reproduce:
1. On a busy MySQL server run:

service mysqld restart

OR

On many of our RHL machines push mysql update from RHN (and let rpm do
the service mysqld condrestart from postinstall script)

2. Watch service get killed, but not restarted.
3. Writh around in pain as servers need to have MySQL started on.
    
Actual results:
MySQL does not come after package upgrade.

Expected results:
MySQL restart to work.

Additional info:
Initscript stop function should run mysqladmin shutdown and also loop with a
sleep waiting for pid file to disappear before returning.
Comment 1 Patrick Macdonald 2003-10-14 10:38:59 EDT
This is a known problem and we have a fix for it but I haven't had time to
put it in.  Anyway, this is a duplicate of bug #58732.  It should be in by
end of the month.

*** This bug has been marked as a duplicate of 58732 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.