Bug 106838 - rhgb does not initiate 3Com PCMCIA properly
rhgb does not initiate 3Com PCMCIA properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-11 10:55 EDT by Miloš Komarčević
Modified: 2013-04-02 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 10:40:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output with rhgb (9.13 KB, text/plain)
2003-10-11 10:57 EDT, Miloš Komarčević
no flags Details
dmesg output with nogui (9.14 KB, text/plain)
2003-10-11 11:00 EDT, Miloš Komarčević
no flags Details

  None (edit)
Description Miloš Komarčević 2003-10-11 10:55:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
The 3Com 3c575 PCMCIA adapter is not initiated properly
during rhgb, although all the lines when showing extra
information pass with service status OK.

After nfslock service the status display changes from "[ OK ]"
to "Ä OK Ü", I don't know if that's related though.



Version-Release number of selected component (if applicable):
rhgb-0.10.2-1

How reproducible:
Always

Steps to Reproduce:
1. Boot machine with rhgb
2. Try to access network (ping, www, ...)
    

Actual Results:  Network not working although the adapter seems to be up 
(module loaded and link light on)

Expected Results:  Working network adapter

Additional info:

A manual restart of pcmcia and networks services usually brings 
the adapter back and I have a working network.

There is no problem with the network if I boot without rhgb
with the nogui option passed to the kernel.

I'm also not sure how this relates to the problem of other
3c59x based cards:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100470

I've tried both the current 2.4.22-1.2087.nptl and arjan's 2.6.0-0.test7.1.52
with the same result (although with 2.6 I can't
even manually restart the network service)
Comment 1 Miloš Komarčević 2003-10-11 10:57:01 EDT
Created attachment 95116 [details]
dmesg output with rhgb
Comment 2 Miloš Komarčević 2003-10-11 11:00:32 EDT
Created attachment 95117 [details]
dmesg output with nogui

Oh yes, and this adapter worked without a hitch with RHL 7.3, 8.0, 9, 
Null, Phoebe etc. - before rhgb appeared anyway.
Comment 3 Bill Nottingham 2003-10-14 00:40:32 EDT
Hm, no actual difference between the ethernet messages there. The character set
changing is a red herring; that's the keytable init script.
Comment 4 Miloš Komarčević 2003-10-14 15:01:59 EDT
I don't know if it's only an ethernet problem: I have to restart pcmcia before I
can get the card working, so it might be a cs problem only?

Anything I can do to help debug this?
Comment 5 Miloš Komarčević 2003-10-19 07:40:27 EDT
There is more rhgb+kernel oddity:

I have an IBM Thikpad 600E with cs423x sound, and to get it working I used a
workaround suggested by IBM 

http://www-1.ibm.com/support/docview.wss?rs=0&q=linux+600e&uid=psg1MIGR-4BP6Q6&loc=en_US&cs=utf-8&cc=us&lang=en

which has worked great until Severn+rhgb, and works as expected w/o rhgb. If I
boot with rhgb, I have to remove and load the cs4232 module once again after
rhgb in order to get the sound working properly. And again there is no
difference in dmesg output.

So there seems to be a general problem with loading kernel modules (or at least
3c59x and cs4232) when rghb is up during init.

Now running:
kernel-2.4.22-1.2097.nptl
initscripts-7.38-1
rhgb-0.11-1
Comment 6 Miloš Komarčević 2003-10-25 07:21:52 EDT
Another thing, if I don't restart pcmcia manually after boot,
the machine freezes when shutting down with

Stopping pcmcia:
Comment 7 Barry K. Nathan 2003-10-26 12:11:33 EST
I've had that problem too, albeit very intermittently (i.e., it happens, but
very rarely). When it does happen, the machine "unfreezes" and continues
shutting down if I yank the 3com card out.
Comment 8 Miloš Komarčević 2003-11-09 12:58:04 EST
Problem still persists in Yarrow.
Comment 9 Simon Matter 2003-12-26 05:38:30 EST
I had the same problem with a DELL Latitude CPx and 3COM PCMCIA NIC.
After trying to figure out what the problem is for hours, I found this
bugzilla post, disabled rhgb and everything works well.
Comment 10 Larry Roberts 2004-01-10 01:28:55 EST
Fedora Core w/ 2.6.1 ( and 2.6.0/2.4.x kernels)
boot to GUI with rhgb causes /etc/rc.d/pcmcia/network NOT to be run.
if either of above is NOT met ( either boot to 3, or removal of 
rhgb ) pcmcia/network starts fine.

My machine:
Dell C800
Aironet 350 Wireless Card

I have edited rc.sysinit to search for some special variables, and 
then cp a special /etc/rc.d/pcmcia/network file depending upon what I 
enter. This file has several debug outputs, consisting of simple 
echo's that I don't see with rhgb in place
Comment 11 Larry Roberts 2004-01-10 01:30:38 EST
Edit the about to read :

/etc/pcmcia/network NOT /etc/rc.d/pcmcia/network

And yes, Im going to bed now :)
Comment 12 Larry Roberts 2004-01-10 01:30:57 EST
Edit the about to read :

/etc/pcmcia/network NOT /etc/rc.d/pcmcia/network

And yes, Im going to bed now :)
Comment 13 Miloš Komarčević 2004-01-10 07:42:44 EST
There is another workaround reported at bug 100920
I guess this one can be closed as a dup
Comment 14 Miloš Komarčević 2004-04-02 10:40:59 EST
Working as expected again in FC2 test2, closing.

Note You need to log in before you can comment on or make changes to this bug.