Bug 106852 - mozilla is hardcoded
mozilla is hardcoded
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-12 00:11 EDT by Marius Andreiana
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 10:22:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2003-10-12 00:11:28 EDT
In RHL9, redhat-web.desktop was called "Internet Browser" and launched htmlview
%s. We could change the behaviour in /etc/htmlview.conf (excellent!)

Now the menu item is called "Mozilla Internet Browser" and launches mozilla.
Please switch back to htmlview
Comment 1 Mike A. Harris 2003-10-12 18:10:17 EDT
The htmlview package has nothing to do with this issue at all.
Comment 2 Marius Andreiana 2003-10-12 18:27:03 EDT
I've put it in html view as
rpm -qf /usr/share/applications/redhat-web.desktop
htmlview-2.0.0-10
Comment 3 Havoc Pennington 2003-10-14 00:05:53 EDT
I don't know why the .desktop file is in htmlview, but having it hardcode
mozilla is correct.

htmlview is a broken, bad idea in general, but in this specific case the reason
it sucks is: it can't appear in desktop files because you can't get fields such
as Name, StartupNotify, and so forth correct if you don't know 
which browser will launch.

So the default browser .desktop file has to hardcode mozilla. If you want
another browser just drag its desktop file to the panel.

Punting to mozilla in case Chris wants to move the .desktop file out of the
htmlview package or add comments.
Comment 4 Christopher Blizzard 2003-10-16 12:56:44 EDT
I think the .desktop file is in the htmlview package "because it seemed like a
good idea at the time."  I'd personally just rather have it in Mozilla myself.
Comment 5 Nicholas Miell 2005-01-13 04:36:25 EST
This bug appears to be fixed (or, at the very least, no longer applicable) --
all of the .desktop files in the htmlview package invoke htmlview and mozilla
has a .desktop file of it's own (which invokes mozilla).
Comment 6 Christopher Blizzard 2005-01-13 10:22:00 EST
Marking worksforme

Note You need to log in before you can comment on or make changes to this bug.