Bug 1068692 - fence_apc: Parse error: Ignoring unknown option 'nodename=dash-03
Summary: fence_apc: Parse error: Ignoring unknown option 'nodename=dash-03
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents
Version: 7.0
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-21 16:57 UTC by Justin Payne
Modified: 2015-03-05 09:06 UTC (History)
5 users (show)

Fixed In Version: fence-agents-4.0.11-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 09:06:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0393 0 normal SHIPPED_LIVE fence-agents bug fix and enhancement update 2015-03-05 14:00:54 UTC

Description Justin Payne 2014-02-21 16:57:26 UTC
Description of problem:
While running brawl, We see the errors listed below in "Actual results"

Version-Release number of selected component (if applicable):
4.0.2-13.el7

How reproducible:
Often

Steps to Reproduce:
1.Run the sts test suite, in my case vedder/gfs2
2.Watch syslog on all nodes
3.

Actual results:
Feb 20 21:18:17 dash-01 stonith-ng[16023]: notice: can_fence_host_with_device: apc-fencing can fence dash-03 (aka. '4'): static-list
Feb 20 21:18:17 dash-01 stonith-ng[16023]: notice: can_fence_host_with_device: apc-fencing can fence dash-03 (aka. '4'): static-list
Feb 20 21:18:17 dash-01 fence_apc: Parse error: Ignoring unknown option 'nodename=dash-03
Feb 20 21:18:20 dash-01 corosync[16006]: [TOTEM ] A processor failed, forming new configuration.
Feb 20 21:18:22 dash-01 corosync[16006]: [TOTEM ] A new membership (10.15.89.168:36) was formed. Members left: 3
Feb 20 21:18:22 dash-01 crmd[16027]: notice: peer_update_callback: Our peer on the DC is dead
Feb 20 21:18:22 dash-01 crmd[16027]: notice: do_state_transition: State transition S_NOT_DC -> S_ELECTION [ input=I_ELECTION cause=C_CRMD_STATUS_CALLBACK origin=peer_update_callback ]
Feb 20 21:18:22 dash-01 kernel: [41651.212311] dlm: closing connection to node 3
Feb 20 21:18:22 dash-01 corosync[16006]: [QUORUM] Members[2]: 1 2
Feb 20 21:18:22 dash-01 crmd[16027]: notice: crm_update_peer_state: pcmk_quorum_notification: Node dash-03[3] - state is now lost (was member)
Feb 20 21:18:22 dash-01 pacemakerd[16021]: notice: crm_update_peer_state: pcmk_quorum_notification: Node dash-03[3] - state is now lost (was member)

Expected results:
No parse errors

Additional info:

Comment 2 Nate Straz 2014-02-21 17:35:54 UTC
I'm seeing this a lot during recovery testing:

Feb 13 15:26:29 buzz-01 fence_apc: Parse error: Ignoring unknown option 'nodename=buzz-02
Feb 20 16:46:42 west-01 fence_apc_snmp: Parse error: Ignoring unknown option 'nodename=west-04

Comment 3 Fabio Massimo Di Nitto 2014-02-24 09:04:18 UTC
Can you please show us how you configure the fence agent?

nodename does not appear to be a valid option in rhel7. Looks like a rhel6 leftover in some configuration files you might be using.

Comment 4 Marek Grac 2014-02-24 11:41:09 UTC
From fence agents perspective, this is a correct respond. We are ignoring it but let other knows it.

@Fabio: nodename is used also in fence_scsi (RHEL7 too)

Comment 5 Nate Straz 2014-02-24 14:31:33 UTC
Here is an example of how we configure the fence agent:

pcs stonith create west-apc fence_apc_snmp params ipaddr="west-apc" pcmk_host_map="west-01:2;west-02:3;west-03:4;west-04:5;west-05:6;west-06:7;west-07:9;west-08:10;west-09:11;west-10:12;west-11:13;west-12:14;west-13:15;west-14:17;west-15:18;west-16:19" action="reboot" debug="1" pcmk_host_check="static-list" pcmk_host_list="west-01,west-02,west-03,west-04,west-05,west-06,west-07,west-08,west-09,west-10,west-11,west-12,west-13,west-14,west-15,west-16"

Comment 7 Marek Grac 2014-04-07 13:58:46 UTC
Can be easilly fixed but perhaps the origin should be fixed. 

Unit test:

fence_apc
on STDIN: nodename=x / ENTER / CTRL+D

pre:
WARNING:root:Parse error: Ignoring unknown option 'nodename=x'
ERROR:root:Failed: You have to set login name
ERROR:root:Please use '-h' for usage

after:
ERROR:root:Failed: You have to set login name
ERROR:root:Please use '-h' for usage

Comment 9 Andrew Beekhof 2014-07-14 00:22:10 UTC
The API (https://fedorahosted.org/cluster/wiki/FenceAgentAPI) says:

"Note that fenced always passes the name of the node to be fenced via the nodename argument."

So Pacemaker is just following orders and this should definitely be handled in the agent(s)

Comment 10 Marek Grac 2014-07-14 09:34:59 UTC
ok, nodename is ignored now

Fixed in upstream

Unit test:

[marx@hroch apc]$ fence_apc
nodename=abc
Failed: You have to set login name

Please use '-h' for usage

[marx@hroch apc]$ fence_apc
xylophone=true
WARNING:root:Parse error: Ignoring unknown option 'xylophone=true'

ERROR:root:Failed: You have to set login name

Failed: You have to set login name

ERROR:root:Please use '-h' for usage

Please use '-h' for usage

previously:
there was no difference between xylophone and nodename

Comment 11 Marek Grac 2014-09-03 11:55:50 UTC
Patch is part of fence agents 4.0.11 release

Comment 15 errata-xmlrpc 2015-03-05 09:06:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0393.html


Note You need to log in before you can comment on or make changes to this bug.