Bug 106879 - ver 0.6.47.11-1 is missing a dependency on cups (pr meta-' print-server')
ver 0.6.47.11-1 is missing a dependency on cups (pr meta-' print-server')
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-12 20:34 EDT by R P Herrold
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 09:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2003-10-12 20:34:12 EDT
[root@ftp log]# redhat-config-printer-tui
Initializing alchemist edit environment ...
Initializing linux printing database ...
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-tui", line 8, in ?
    printconf_tui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_tui.py", line 2345, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_tui.py", line 1975, in tui_main_run
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
[root@ftp log]# rpm -qa | grep lp
perl-XML-Grove-0.46alpha-25
[root@ftp log]# rpm -qa | grep cup
cups-libs-1.1.17-13.3
[root@ftp log]# rpm -V redhat-config-printer
[root@ftp log]# rpm -qi redhat-config-printer
Name        : redhat-config-printer        Relocations: (not relocateable)
Version     : 0.6.47.11                         Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Tue 16 Sep 2003 07:26:18
AM EDT
Install Date: Sun 12 Oct 2003 08:09:44 PM EDT      Build Host: daffy.perf.redhat.com
Group       : System Environment/Daemons    Source RPM:
redhat-config-printer-0.6.47.11-1.src.rpm
Size        : 1638927                          License: GPL
Signature   : DSA/SHA1, Tue 16 Sep 2003 12:25:48 PM EDT, Key ID 219180cddb42a60e

====================================================================

manually adding 'cups' solves the issue -- a "Requires: cups" seems in order, or
a virtual "Requires: print-server", and configuring cups to 'Provides:
print-server' if one wants backward support path for lpr. lpr-ng, and so forth
Comment 1 Tim Waugh 2003-10-13 04:49:22 EDT
No, this should work fine with LPRng.  What does '/usr/sbin/alternatives
--display print' say?
Comment 2 Miloslav Trmac 2003-10-13 06:42:51 EDT
This is a duplicate of bug 85363. 
Comment 3 R P Herrold 2003-10-13 09:04:55 EDT
Recall that I manually added 'cups' to get it working:  After that, it says:


[herrold@ftp herrold]$ /usr/sbin/alternatives --display print
print - status is auto.
 link currently points to /usr/bin/lpr.cups
/usr/bin/lpr.cups - priority 40
 slave print-lp: /usr/bin/lp.cups
 slave print-lpq: /usr/bin/lpq.cups
 slave print-lprm: /usr/bin/lprm.cups
 slave print-lpstat: /usr/bin/lpstat.cups
 slave print-cancel: /usr/bin/cancel.cups
 slave print-lpc: /usr/sbin/lpc.cups
 slave print-cancelman: /usr/share/man/man1/cancel-cups.1.gz
 slave print-lpman: /usr/share/man/man1/lp-cups.1.gz
 slave print-lpcman: /usr/share/man/man8/lpc-cups.8.gz
 slave print-lpqman: /usr/share/man/man1/lpq-cups.1.gz
 slave print-lprman: /usr/share/man/man1/lpr-cups.1.gz
 slave print-lprmman: /usr/share/man/man1/lprm-cups.1.gz
 slave print-lpstatman: /usr/share/man/man1/lpstat-cups.1.gz
Current `best' version is /usr/bin/lpr.cups.
[herrold@ftp herrold]$

And redhat-config-printer is not interlocked from breaking printing again.  It
should have complained with the following, but it did not:

[herrold@ftp herrold]$ sudo rpm -e cups
Password:
warning: /etc/cups/printers.conf saved as /etc/cups/printers.conf.rpmsave
warning: /etc/cups/cupsd.conf saved as /etc/cups/cupsd.conf.rpmsave
[herrold@ftp herrold]$ /usr/sbin/alternatives --display print
[herrold@ftp herrold]$

so it appears an explicit dependency, possibly on a pseudo meta-package, is
required.

BTW -- this host was a "kickstart" 'from scratch' new build, after a hard drive
died last week.  
Comment 4 R P Herrold 2003-10-13 09:06:47 EDT
chuckle:   I just read Miloslav's dupe, referenced, and Tim's comment there was:

""------- Additional Comment #3 From Tim Waugh on 2003-08-08 04:04 -------

redhat-config-printer should require cups.""

Comment 5 Tim Waugh 2003-10-13 09:21:43 EDT
Oh, not a standard install.  Well, yes, you need to install a print spooler for
redhat-config-printer to work.

LPRng is not shipped any more, so the requirement is already there in rawhide --
but there is no plan to add a meta-requirement for existing releases.

Note You need to log in before you can comment on or make changes to this bug.