Bug 10689 - Multicast doesn't work unless promisc or allmulti is on
Summary: Multicast doesn't work unless promisc or allmulti is on
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-10 04:15 UTC by matt.domencic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 20:48:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description matt.domencic 2000-04-10 04:15:15 UTC
I'm using 6.0 and a Xircom PCMCIA ethernet card (xirc2ps_cs).

MULTICAST is enabled (so says ifconfig)

However, I can't receive multicast packets unless the interface is switched
to PROMISC or ALLMULTI.  I do see that the multicast group was joined (via
/proc/net/igmp), but no packets arrive.

Comment 1 Anonymous 2000-04-10 21:49:59 UTC
As it turns out this may not be a bug - it is definitely a behavior difference
between the 2.0.x and 2.2.x kernel though.  In 2.0.x you are permitted to create
a socket, join a group, and then bind the socket to the multicast address you
are interested in.  In 2.2.x, you must bind first, and then join the group.

Comment 2 Anonymous 2000-04-10 23:03:59 UTC
Argh.  Scratch that.  It still will not work under 2.2.x, but works beautifully
in all possible ways under 2.0.x.

I have now verified this behavior with several ethernet cards using different
drivers.

Comment 3 Anonymous 2000-04-27 21:51:59 UTC
I've tracked down the problem further.  It only happens with a PCMCIA ethernet
card.  A regular ethernet card works fine.  The behavior happens with both
pcmcia-cs 3.1.10 and 3.1.14

Comment 4 Jeff Johnson 2000-05-15 10:26:59 UTC
This is a kernel problem. Changing component.

Comment 5 Alan Cox 2000-08-08 20:48:35 UTC
Does this still occur with 3.1.18

Comment 6 Alan Cox 2000-08-08 20:48:53 UTC
Does this still occur with 3.1.18


Note You need to log in before you can comment on or make changes to this bug.