Bug 106899 - Writing DVD-R(W) freezes machine on fixate
Writing DVD-R(W) freezes machine on fixate
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 01:59 EDT by Alan Olsen
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Olsen 2003-10-13 01:59:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807

Description of problem:
If I try and burn a DVD under Redhat 9, the system will freeze and the capslock
light will come on when it starts to fixate the disc. (The resulting disc passes
all MD5 checksums.)

This did not happen under Redhat 7.3.  I don't think it happened under Redhat
8.0 either.

The last recorded messages in /var/log/messages are:
Oct 12 19:59:12 zontar kernel: scsi : aborting command due to timeout : pid
1641944, scsi0, channel 0, id 0, lun 0 Synchronize Cache 00 00 00 00 00 00 00 00 00
Oct 12 19:59:12 zontar kernel: hdc: irq timeout: status=0xd0 { Busy }
Oct 12 19:59:34 zontar modprobe: modprobe: Can't locate module char-major-81

The last one is weird because I do not have a tuner card.  (I have a video
capture card (Canopus), but that shows up as firewire.)  It could be the nVIDIA
card being weird.  I can turn that off and test again.

The other odd thing is that the hang only occurs if the DVD is larger than about
4 gigs. (I burned a 3.7 gig disc with the same setup and it worked fine.  The
4.1 gig disc did not.)

I have tried this using DVDPro ( a closed source hack to cdrecord) and using the
DVD+rw-tools package required by the cvs version of k3b. The DVD+RW-tools
package was compiled from the current version.

Neither should hang the system. (No respond to ping from any other machines. 
Its dead Jim.)

Reboots are a bitch with 360 gigs of hard drive.  (I don't trust ext3 yet.)

The system is a dual Athlon 2100+MP (dual CPU). 

Here is the lspci:
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP
Bridge00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ISA (rev 05)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768 [Opus] IDE (rev 04)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI (rev 03)
00:07.5 Multimedia audio controller: Advanced Micro Devices [AMD] AMD-768 [Opus]
Audio (rev 03)
00:09.0 FireWire (IEEE 1394): NEC Corporation: Unknown device 00f2 (rev 01)
00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 05)
01:05.0 VGA compatible controller: nVidia Corporation: Unknown device 0322 (rev a1)
02:05.0 USB Controller: NEC Corporation USB (rev 41)
02:05.1 USB Controller: NEC Corporation USB (rev 41)
02:05.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
02:06.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 0c)

Here are the loaded modules:
i810_audio             28296   1  (autoclean)
ac97_codec             14664   0  (autoclean) [i810_audio]
soundcore               7108   2  (autoclean) [i810_audio]
agpgart                48736   3  (autoclean)
nvidia               1766048  11
lp                      9028   0  (autoclean)
parport                38816   0  (autoclean) [lp]
autofs                 13556   0  (autoclean) (unused)
e100                   55652   1
sg                     36780   0  (autoclean)
sr_mod                 17752   0  (autoclean)
ide-scsi               12144   0
scsi_mod              109720   3  [sg sr_mod ide-scsi]
ide-cd                 35520   0
cdrom                  33664   0  [sr_mod ide-cd]
ohci1394               20648   0  (unused)
ieee1394               52076   0  [ohci1394]
scanner                11740   0  (unused)
keybdev                 2944   0  (unused)
mousedev                5592   1
hid                    22084   0  (unused)
input                   6112   0  [keybdev mousedev hid]
ehci-hcd               20296   0  (unused)
usb-ohci               21896   0  (unused)
usbcore                82080   1  [scanner hid ehci-hcd usb-ohci]

Here is the cdrecord --scanbus results:

[root@zontar root]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J�rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'PIONEER ' 'DVD-RW  DVR-105 ' '1.21' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

Ideas?  I do not want to have to reinstall this system.

I am willing to try another kernel, but I am concerned about nptl compatibility
with Redhat 9.



Version-Release number of selected component (if applicable):
kernel-smp-2.4.20-18.9-athlon

How reproducible:
Always

Steps to Reproduce:
1.Try to burn DVD greater than 4 gigs.
2. Watch it crash and burn.
3.
    

Actual Results:  Frozen machine. Capslock light on.

Expected Results:  Should have ejected the disc after fixating.  

Additional info:
Comment 1 Alan Olsen 2003-10-13 15:31:01 EDT
Updating to 2.4.20-20.9 fixes the freeze problem.  The drive will occasionally
refuse to eject the disc now.  That is solvable by reboot.  Much faster than
fsck on 360 gigs. At least it reduces the severity of the problem.
Comment 2 Bugzilla owner 2004-09-30 11:41:35 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.