Bug 106919 - X(ati) does not resume from blank mode (DPMS?)
X(ati) does not resume from blank mode (DPMS?)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 11:28 EDT by Tru Huynh
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Vesa config file (working) (3.05 KB, text/plain)
2003-10-14 03:53 EDT, Tru Huynh
no flags Details
Ati config file (not working) (3.06 KB, text/plain)
2003-10-14 03:54 EDT, Tru Huynh
no flags Details
config file and logs (ati wo VideoRam line) (15.13 KB, application/octet-stream)
2003-10-15 03:44 EDT, Tru Huynh
no flags Details
XF86Config (ati wo VideoRam) (3.05 KB, text/plain)
2003-10-15 05:42 EDT, Tru Huynh
no flags Details
XFree86.0.log (43.12 KB, text/plain)
2003-10-15 05:44 EDT, Tru Huynh
no flags Details
XFree86.0.log.old (43.11 KB, text/plain)
2003-10-15 05:47 EDT, Tru Huynh
no flags Details

  None (edit)
Description Tru Huynh 2003-10-13 11:28:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030708

Description of problem:
When using init 5, and the ati driver can not recover from blank display. Upon
keyboard/mouse activation the display keeps blinking,trying to return from blank
to locked display.


Version-Release number of selected component (if applicable):
XFree86-4.3.0-32.EL

How reproducible:
Always

Steps to Reproduce:
1.taroon with all patches Tue Oct  7 15:11:57 2003
2.4 way opteron machine 842, 3.5 GB of RAM
3.init 5 and leave the blanking occur.
    

Actual Results:  X can not resume from blanking.

Expected Results:  X working

Additional info:


This does *NOT* occur when using the vesa driver (ati->vesa in
the XF86Config file).

This does not occur when used with init 3 (textmode only).

This does occur with either SMP or UP kernels from RedHat
kernel-2.4.21-3.EL,kernel-smp-2.4.21-3.EL (w/wo acpi=off)
or rebuild kernel from kernel-source with ACPI disabled
at compile time.


[root@localhost X11]# grep -v '#' XF86Config.ati| grep -v '^$'
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection
Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "fr"
EndSection
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
Section "InputDevice"
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Moniteur non détecté"
        HorizSync    31.5 - 37.9
        VertRefresh  50.0 - 70.0
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Mach64"
        VideoRam    8192
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection
EndSection
Section "DRI"
        Group        0
        Mode         0666
EndSection
Comment 1 Mike A. Harris 2003-10-14 02:51:44 EDT
Remove the "VideoRAM" setting from your config file, and report the
results.  Then please attach the new config file and log file to the
bug report as bugzilla file attachments using the link below.  (Do not
cut and paste huge files into the comment area as above please.)

Thanks in advance.
Comment 2 Tru Huynh 2003-10-14 03:53:59 EDT
Created attachment 95156 [details]
Vesa config file (working)
Comment 3 Tru Huynh 2003-10-14 03:54:50 EDT
Created attachment 95157 [details]
Ati config file (not working)
Comment 4 Tru Huynh 2003-10-14 06:08:07 EDT
The immediate blanking happens as soon as the mouse stops moving,
as if the delay was set to 0 second. 

As long as the mouse is moving, the desktop is visible.

This is true for the ATI driver with and without the VideoRam line.

Regards,

Tru
Comment 6 Mike A. Harris 2003-10-14 12:45:26 EDT
Just to clarify what I requested above, please do the following steps:

- If you boot into runlevel 5, log out of X, switch to a text console, log
  in as root, and type "init 3" to switch to runlevel 3.
- Run "redhat-config-xfree86 --reconfig"
- Edit the /etc/X11/XF86Config file, and remove the VideoRAM line
- Save the file, then type "startx"
- Make a backup copy of /etc/X11/XF86Config and also /var/log/XFree86.0.log*
- Using bugzilla file attachment feature, attach the config file generated
  by the above steps, and also all log files from /var/log/XFree86.0.log*
  so that I can see how the server is starting.

Thanks in advance.
Comment 7 Tru Huynh 2003-10-15 03:44:59 EDT
Created attachment 95188 [details]
config file and logs (ati wo VideoRam line)
Comment 8 Tru Huynh 2003-10-15 03:47:08 EDT
it is a gzipped tarball, not a text/plain file.
Sorry!

Tru
Comment 9 Mike A. Harris 2003-10-15 04:57:25 EDT
Individual uncompressed one file per attachment, viewable by clicking on it
in a web browser please.  I'll have a look once you attach the files.

Thanks.
Comment 10 Tru Huynh 2003-10-15 05:42:42 EDT
Created attachment 95195 [details]
XF86Config (ati wo VideoRam)
Comment 11 Tru Huynh 2003-10-15 05:44:07 EDT
Created attachment 95197 [details]
XFree86.0.log
Comment 12 Tru Huynh 2003-10-15 05:47:21 EDT
Created attachment 95198 [details]
XFree86.0.log.old
Comment 13 Mike A. Harris 2003-10-15 07:10:13 EDT
Unfortunately, you are not using a Red Hat supplied kernel, and it is
entirely possible that this problem is caused by your custom kernel.

Please try to reproduce the problem while booted into an official Red Hat
supplied binary kernel, and using no 3rd party kernel modules.  Run the X
server again, and attach the XFree86.0.log* and /var/log/messages from the
new test.

Comment 14 Tru Huynh 2003-10-15 07:48:22 EDT
the running kernel has been recompiled from the kernel-source + configs
(x86_64 SMP) and disabling ACPI completely that's all.
Although I agree that this is not a supported kernel, I really believe
this is not related.
Nevertheless I will do as you say.

Tru 
Comment 15 Mike A. Harris 2004-10-01 02:35:30 EDT
Red Hat supplied kernels must be used to reproduce any bugs that
are experienced in the OS.  If you still can reproduce this with
a Red Hat supplied kernel in Fedora Core 2 or later, please feel
free to supply the X server log, config file, and /var/log/messages
as file attachments and reopen this bug and we will reinvestigate
the issue.

Setting status to WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.