Bug 1069201 - [REST]: Missing domain field on VM\Template object.
Summary: [REST]: Missing domain field on VM\Template object.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 3.4.0
Assignee: Shahar Havivi
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-24 13:08 UTC by Ilanit Stein
Modified: 2014-03-31 12:24 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:24:40 UTC
oVirt Team: ---


Attachments (Terms of Use)
VM test logs (1.35 MB, application/x-bzip2)
2014-02-24 13:08 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25154 0 None MERGED core, restapi: Missing domain field on VM\Template object Never
oVirt gerrit 25181 0 None MERGED core, restapi: Missing domain field on VM\Template object Never
oVirt gerrit 25373 0 None MERGED restapi: set domain for vm-init Never
oVirt gerrit 25426 0 None MERGED restapi: set domain for vm-init Never
oVirt gerrit 25531 0 None MERGED restapi: set domain for vm-init Never

Description Ilanit Stein 2014-02-24 13:08:07 UTC
Created attachment 866963 [details]
VM test logs

Description of problem:

Regression for "domain" field is missing in REST VM\Template object.

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.11.beta3.el6.noarch

Bug appear from version:
ovirt-engine-3.4.0-0.7.beta2.el6.noarch
and wasn't on:
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

How reproducible:
100% - at all VM test run:
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Compute/view/3.4-git/view/Virt/job/3.4-git-compute-virt-reg_vms-rest-nfs/36/ 
Failing case:
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Compute/view/3.4-git/view/Virt/job/3.4-git-compute-virt-reg_vms-rest-nfs/36/testReport/junit/Templates/118-Check%20whether%20there%20is%20template%20with%20specific%20domain%20name/Check_whether_there_is_template_with_specific_domain_name/

Comment 1 Juan Hernández 2014-02-26 10:34:37 UTC
Shahar, can you take a look at this? I think it may be related to the introduction of VmInit.

Comment 2 Sandro Bonazzola 2014-03-03 14:40:34 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 4 Michal Skrivanek 2014-03-05 13:48:06 UTC
since this was identified as a blocker it needs to go to 3.4

Comment 5 Sandro Bonazzola 2014-03-31 12:24:40 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.