Bug 1069214 - Filter returns empty list if the plugin filter method is failing
Summary: Filter returns empty list if the plugin filter method is failing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-scheduler-proxy
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.3.2
Assignee: Martin Sivák
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On: 1002444
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-24 13:30 UTC by rhev-integ
Modified: 2016-02-10 20:18 UTC (History)
10 users (show)

Fixed In Version: ovirt-scheduler-proxy-0.1.3-5.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, when external filters failed, the scheduling proxy returned an empty list of available hosts. This meant that virtual machines could not be started. A fix now makes Red Hat Enterprise Virtualization ignore the failure of external filters, and that means that the full list of available hosts is returned to the engine. Virtual machines can now be restarted, and it is as though the failing plugin was not ever called.
Clone Of: 1002444
Environment:
Last Closed: 2014-04-09 17:42:46 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0388 normal SHIPPED_LIVE ovirt-scheduler-proxy bug fix and enhancement update 2014-04-09 21:41:15 UTC
oVirt gerrit 18788 None None None Never
oVirt gerrit 21232 None None None Never

Comment 1 Martin Sivák 2014-03-10 13:57:25 UTC
This was already added to https://brewweb.devel.redhat.com/buildinfo?buildID=338585. Should we create an errata for it?

Comment 3 Artyom 2014-03-17 10:48:23 UTC
Verified on ovirt-scheduler-proxy-0.1.3-5

Comment 4 Zac Dover 2014-04-03 03:01:00 UTC
This bug is currently attached to errata RHBA-2014:17259 If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.

Comment 6 errata-xmlrpc 2014-04-09 17:42:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0388.html


Note You need to log in before you can comment on or make changes to this bug.