Bug 1069275 - dracut-004-336 issues when ifname is not specified as kernel parameter
Summary: dracut-004-336 issues when ifname is not specified as kernel parameter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.6
Hardware: Unspecified
OS: All
unspecified
medium
Target Milestone: rc
: 6.6
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-24 16:14 UTC by Marius Boeru
Modified: 2015-07-22 06:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: if "ip=ibft" is specified as a kernel command line argument, but no "ifname=<iface>:<mac>", dracut does not handle network interfaces. Consequence: iSCSI disks will not be connected to the system and the system does not boot. Fix: dracut now handles "ip=ibft" as a kernel command line argument, even without "ifname=<iface>:<mac>". Result: iSCSI disks will be connected to the system and the system boots.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:37:58 UTC


Attachments (Terms of Use)
Proposed patch (1.14 KB, patch)
2014-02-24 16:22 UTC, Harald Hoyer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1328 normal SHIPPED_LIVE dracut bug fix and enhancement update 2015-07-20 17:53:04 UTC

Description Marius Boeru 2014-02-24 16:14:10 UTC
Description of problem:
if no ifname is specified as kernel argument the server will not boot using ip=ibft. It will not find iscsi the root device

Version-Release number of selected component (if applicable): CentOS 6.5


How reproducible:


Steps to Reproduce:
1.Install CentOS using netinstall iso on an iscsi lun
2. after instalation remove ifname=eth0:XX:XX:XX:XX:XX:XX from kernel line
3. try to boot and it will fail

Actual results:
rdinitdebug boot log and init.log: http://pastebin.com/XY4Ahwam

Expected results:
The OS should be able to boot only with ip=ibft and no ifname parameter

Additional info:
fix by haraldh: http://paste.fedoraproject.org/79831/32523561/

dirty fix: set ifname=dummy:FF:FF:FF:FF:FF:FF (or anything else in the same format) as a parameter and the OS will boot from iscsi and will set ibft0 accordingly

Comment 1 Harald Hoyer 2014-02-24 16:22:53 UTC
Created attachment 867046 [details]
Proposed patch

Comment 4 errata-xmlrpc 2015-07-22 06:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1328.html


Note You need to log in before you can comment on or make changes to this bug.