Bug 1069279 - Prevent resources in an anti-colocation from even temporarily running on a same node
Summary: Prevent resources in an anti-colocation from even temporarily running on a sa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-24 16:16 UTC by Frank Danapfel
Modified: 2014-10-14 07:33 UTC (History)
5 users (show)

Fixed In Version: pacemaker-1.1.12-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: The default stop/start ordering of resources made it possible to violate colocation constraints under some conditions Consequence: Resources could temporarily be active on the same node despite a colocation constraint that required them not to be Fix: Imply an ordering constraint that would prevent this when colocation constraints are configured Result: Resources are never on the same node if configured not to be
Clone Of:
: 1069284 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:33:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1544 normal SHIPPED_LIVE pacemaker bug fix update 2014-10-14 01:21:31 UTC

Description Frank Danapfel 2014-02-24 16:16:28 UTC
Description of problem:
Under some circumsatances it can happen that two resources end up running on the same node even though a "anti-colocation" rule (colocation rule with score INFINITY) was set up that should prevent this.

Version-Release number of selected component (if applicable):
pacemaker-1.1.10-14.el6_5.1

How reproducible:
sometimes

Steps to Reproduce:
1. configure two resources that should always run on different nodes
2. set up colocation rule with score INFINITY to prevent the two resources from running on the same node  
3.

Actual results:
under some circumstances both resources end up running on the same node

Expected results:
under no circumstances resources should be running on the same node

Additional info:
I've not discovered this issue myself, but was informed by a colleague from SUSE about it.

A fix for this is available in the following upstream commit:
https://github.com/ClusterLabs/pacemaker/commit/9f9ed87e01bfafec0ddeee6592eb07e81bef963e

Comment 6 errata-xmlrpc 2014-10-14 07:33:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1544.html


Note You need to log in before you can comment on or make changes to this bug.