Bug 1069301 - (CVE-2009-5138) CVE-2009-5138 gnutls: incorrect handling of V1 intermediate certificates
CVE-2009-5138 gnutls: incorrect handling of V1 intermediate certificates
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20090109,repor...
: Security
Depends On: 1069888 1069889 1071851
Blocks: 1065093
  Show dependency treegraph
 
Reported: 2014-02-24 12:13 EST by Tomas Hoger
Modified: 2015-02-04 07:48 EST (History)
12 users (show)

See Also:
Fixed In Version: gnutls 2.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-03 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2014-02-24 12:13:28 EST
While investigating GnuTLS issue CVE-2014-1959 (bug 1065092), it was discovered that older versions of GnuTLS were affected by the same problem, with a different root cause.  When using default certificate verification settings, GnuTLS accepted version 1 X.509 certificates as intermediate CAs.  An attacker able to obtain a V1 certificate from a CA trusted by application could generate certificates for other hosts or users that would be accepted by GnuTLS.

This issue affected GnuTLS versions before 2.7.6.  Problem was reported in the following post:

http://thread.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/3351/focus=3361

and fixed upstream via:

https://gitorious.org/gnutls/gnutls/commit/c8dcbedd1fdc312f5b1a70fcfbc1afe235d800cd

This did not affect applications that used GNUTLS_VERIFY_ALLOW_X509_V1_CA_CRT verification flag, which instructs GnuTLS to allow root CA certificates to be version 1 certificates.  This was set by e.g. gnutls-cli client application in GnuTLS versions affected by this bug.

This issue affects gnutls packages in Red Hat Enterprise Linux 5.  Versions used in Red Hat Enterprise Linux 6 or current Fedora versions are newer than 2.7.6 and are not affected.
Comment 1 Tomas Hoger 2014-02-25 15:50:09 EST
It seems this issue was introduced in upstream version 1.2.1 via:

https://gitorious.org/gnutls/gnutls/commit/e0516d09a008352a3481ea518001ae3f58840a5f
Comment 4 Tomas Hoger 2014-02-27 02:45:42 EST
CVE-2009-5138 was assigned to this issue:

http://thread.gmane.org/gmane.comp.security.oss.general/12127/focus=12227
Comment 5 Tomas Hoger 2014-03-03 05:17:14 EST
Created mingw32-gnutls tracking bugs for this issue:

Affects: epel-5 [bug 1071851]
Comment 6 Tomas Hoger 2014-03-03 05:20:42 EST
Statement:

This issue did not affect the versions of gnutls as shipped with Red Hat Enterprise Linux 6.
Comment 7 errata-xmlrpc 2014-03-03 13:25:55 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2014:0247 https://rhn.redhat.com/errata/RHSA-2014-0247.html

Note You need to log in before you can comment on or make changes to this bug.