Bug 1069419 - Byobu with tmux backend does not remove date and time even if deselected in byobu-config
Summary: Byobu with tmux backend does not remove date and time even if deselected in b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: byobu
Version: 20
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Klepek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 01:03 UTC by Ankur Sinha (FranciscoD)
Modified: 2015-03-28 19:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-28 19:55:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1284392 0 None None None Never

Description Ankur Sinha (FranciscoD) 2014-02-25 01:03:37 UTC
Description of problem:
One cannot remove date and time from the status lines even using byobu-config

Version-Release number of selected component (if applicable):
byobu-5.73-1.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Use byobu with tmux backend
2. Remove date and time in byobu-config
3.

Actual results:
Date and time still show up

Expected results:
Date and time should not show up

Additional info:
From what I can find, this seems to be because /usr/share/profiles/tmux has the line:

set -g status-right '#(byobu-status tmux_right)'$BYOBU_DATE$BYOBU_TIME

Since status-right is not normally overridden by .byobu files, such as .tmux.conf, the date and time are always visible.

Workaround:
In order to remove the date and time from the status line, one has to override this line manually from ~/.byobu/.tmux.conf:

set -g status-right '#(byobu-status tmux_right)'

Comment 1 Jan Klepek 2014-02-25 17:39:19 UTC
waiting for release from upstream

Comment 2 Jan Klepek 2014-02-27 12:01:39 UTC
patch provided to upstream, it is part of byobu-5.73-2 (currently in testing repo)

Comment 3 Fedora Update System 2014-02-27 18:29:08 UTC
byobu-5.73-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/byobu-5.73-3.fc20

Comment 4 Fedora Update System 2014-02-27 18:29:23 UTC
byobu-5.73-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.73-3.el5

Comment 5 Fedora Update System 2014-02-27 18:29:40 UTC
byobu-5.73-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.73-3.el6

Comment 6 Fedora Update System 2014-02-27 18:29:54 UTC
byobu-5.73-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/byobu-5.73-3.fc19

Comment 7 Fedora Update System 2014-02-28 18:08:40 UTC
byobu-5.73-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc19

Comment 8 Fedora Update System 2014-02-28 18:09:08 UTC
byobu-5.73-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el5

Comment 9 Fedora Update System 2014-02-28 18:09:32 UTC
byobu-5.73-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/byobu-5.73-4.el6

Comment 10 Fedora Update System 2014-02-28 18:10:07 UTC
byobu-5.73-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/byobu-5.73-4.fc20

Comment 11 lnie 2014-03-03 05:08:02 UTC
byobu-5.73-4.fc20 works

Comment 12 Fedora Update System 2014-03-15 19:51:27 UTC
byobu-5.73-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-03-15 19:51:51 UTC
byobu-5.73-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-03-17 03:55:34 UTC
byobu-5.73-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2014-03-17 03:56:27 UTC
byobu-5.73-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.