Bug 106947 - Unable to transfer files with 3c575bt NIC
Unable to transfer files with 3c575bt NIC
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 17:18 EDT by David Hart
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 23:33:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hart 2003-10-13 17:18:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:

Using a 3Com 575 BT PCMCIA NIC (cardbus), I am able to maintain normal external
connections to the internet. However, any attempt to transfer large amounts of
data of the LAN stalls, with the following error message:

Oct 13 17:13:04 main kernel: nfs: server mail2.tqmcube.com not responding, still
trying
Oct 13 17:13:04 main last message repeated 4 times
Oct 13 17:13:09 main kernel: NETDEV WATCHDOG: eth0: transmit timed out
Oct 13 17:13:09 main kernel: eth0: transmit timed out, tx_status 00 status e601.
Oct 13 17:13:09 main kernel:   diagnostics: net 0cc2 media a800 dma 0000003a.
Oct 13 17:13:09 main kernel: eth0: Interrupt posted but not delivered -- IRQ
blocked by another device?
Oct 13 17:13:09 main kernel:   Flags; bus-master 1, dirty 39658(10) current
39658(10)
Oct 13 17:13:09 main kernel:   Transmit list 00000000 vs. c036d480.

Version-Release number of selected component (if applicable):
3.1.31-13

How reproducible:
Always

Steps to Reproduce:
1. Attempt to move larger files or directories from the server to a client using
NFS, FTP or SFTP.
2.
3.
    

Actual Results:  Transfer stalls and system becomes unstable for a couple of minutes

Expected Results:  Normal data transfer.

Additional info: Booting the client to WinXP provides perfect results (same
server, NIC and router).

Moreover, in Win the card advertises as full duplex. In linux it advertises as
half duplex and cannot be forced to full duplex which is probably the heart of
the problem.
Comment 1 David Hart 2003-11-10 14:41:26 EST
Problem continues with no improvement in Fedora Core 1, kernel 
2.4.22-1.2115.nptl (in fact it seems a tad worse). Custom compiling
with the driver compiled into the kernel provides no improvement either.

Setting the partner NIC to HD offers some improvement but the issue is
still present.
Comment 2 Don 2004-04-15 07:46:22 EDT
Same problem, here, on ThinkPad T21.  Ejecting card and re-inserting
"fixes" the issue.  Seems to be a problem with resource allocation:

Interrupt posted but not delivered -- IRQ blocked by another device?

Did not have this problem on same machine running RedHat 9 or Debian
Woody.

Note You need to log in before you can comment on or make changes to this bug.