Bug 1069528 - microcode: failed to load file amd-ucode/microcode_amd_fam15h.bin [NEEDINFO]
Summary: microcode: failed to load file amd-ucode/microcode_amd_fam15h.bin
Status: CLOSED DUPLICATE of bug 866700
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Anton Arapov
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 08:13 UTC by Xiaoqing Wei
Modified: 2016-01-11 00:46 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-02-25 10:48:16 UTC
mm13: needinfo? (anton)
mm13: needinfo? (anton)


Attachments (Terms of Use)

Description Xiaoqing Wei 2014-02-25 08:13:40 UTC
Description of problem:

observing 'microcode: failed to load file amd-ucode/microcode_amd_fam15h.bin' from journalctl

Version-Release number of selected component (if applicable):
kernel-3.10.0-95.el7.x86_64
microcode_ctl-2.1-5.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. boot a Hewlett-Packard 500-091cn
2.
3.

Actual results:
Feb 25 11:13:07 dhcp-8-238.nay.redhat.com kernel: [drm] Loading ARUBA Microcode
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: CPU0: patch_level=0x06001119
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: failed to load file amd-ucode/microcode_amd_fam15h.bin
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: CPU1: patch_level=0x06001119
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: CPU2: patch_level=0x00000000
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: CPU3: patch_level=0x00000000
Feb 25 11:13:13 dhcp-8-238.nay.redhat.com kernel: microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
Feb 25 11:13:55 dhcp-8-238.nay.redhat.com dracut[1395]: *** Generating early-microcode cpio image ***


Expected results:
not warning.

Additional info:
processor	: 3
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 16
model name	: AMD A10-5800K APU with Radeon(tm) HD Graphics  
stepping	: 1
cpu MHz		: 1400.000
cache size	: 2048 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 2
apicid		: 19
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold bmi1
bogomips	: 7586.69
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro

[root@dhcp-8-238 ~]# lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             AuthenticAMD
CPU family:            21
Model:                 16
Model name:            AMD A10-5800K APU with Radeon(tm) HD Graphics
Stepping:              1
CPU MHz:               1400.000
BogoMIPS:              7586.69
Virtualization:        AMD-V
L1d cache:             16K
L1i cache:             64K
L2 cache:              2048K
NUMA node0 CPU(s):     0-3

host installed with RHEL-7.0-20140220.2

Comment 1 Xiaoqing Wei 2014-02-25 08:16:56 UTC
not major incident observed yet(kernel panic)

Comment 2 Anton Arapov 2014-02-25 08:49:13 UTC
moving to kernel. microcode_ctl doesn't have "loader" function in rhel7.

Comment 7 Anton Arapov 2014-02-25 10:48:16 UTC
You see this message because NO amd microcode available at all. I will work on the upstream code to make the message more informative.

*** This bug has been marked as a duplicate of bug 866700 ***

Comment 8 Johnny Hughes 2014-10-30 12:05:11 UTC
Note:  it should be against the rules to close a public bug as a duplicate IF the original bug is not open to the public.  The community also needs to see fixes.

Comment 9 Muhammad Aizuddin 2015-04-20 11:34:22 UTC
i would totally agree with Johnny, community also need to see fixes.

Comment 10 Akemi Yagi 2015-06-10 21:25:15 UTC
If the "other" bug cannot be opened, could someone at RH update the status here? 

Is the plan to update the displayed information but not to actually include amd microcode?

Comment 11 Mauro Mozzarelli 2015-09-29 08:20:34 UTC
bug 866700 is not accessible, the issue persists and the assignee provided indication that the issue might not be addressed correctly thus I will add the following information:

The directory /lib/firmware/amd-ucode containing the following files:
/lib/firmware/amd-ucode/microcode_amd.bin
/lib/firmware/amd-ucode/microcode_amd_fam15h.bin

was omitted from microcode_ctl-2.1-10.el7.x86_64 package.

The temporary solution is to copy the relevant directory from package
microcode_ctl-1.17-20.el6.x86_64 distributed with RHEL 6.6.

Anton Arapov is thus wrong since the microcode IS AVAILABLE, but not packaged in microcode_ctl for RHEL7.

The fix should consist of including the relevant directory and files in the upstream RHEL7 microcode_ctl package.

I also request Anton to clarify on the status given that bug 866700 cannot be accessed. Thank you.

Comment 12 Mark Willert 2015-10-05 12:40:17 UTC
Got the same with an AMD A4-5000, but the missing file is microcode_amd_fam16h.bin

The Microcode is also available from AMD:

http://www.amd64.org/microcode.html

The newest file includes:

- microcode_amd.bin
- microcode_amd_fam15h.bin
- microcode_amd_fam16h.bin

which solve this error message if copied to /lib/firmware/amd-ucode

So this can be solved by packaging the manufactorer's files.

Comment 13 Mauro Mozzarelli 2015-10-05 17:50:43 UTC
Mark,

We know the microcode files are available both from AMD and previous CentOS 6 release packages. 

What is not clear yet is if we are supposed to update the firmware files manually every time or if they will be packaged as expected in the next kernel-firmware package to correct the issue.

Thus I do not consider this issue resolved. I proposed too to re-open this bug until either the files are correctly packaged in kernel-firmware or we have an acknowledgement that they will.

Mauro.

Comment 14 Mark Willert 2015-10-05 18:20:14 UTC
Mauro,

the point was just that CentOS 6 does not pack all available microcode patches, so taking directly from AMD looks like the better choice.

Comment 15 Mauro Mozzarelli 2015-10-05 19:39:38 UTC
It should and it does not take a great deal to copy the AMD firmware in the package.

Comment 16 Kevin Zhang 2015-12-20 04:16:19 UTC
Can confirm this issue on a system with an Athlon II X4 635 (Propus). Downloading and copying latest microcode files from AMD website seems to improve system stability as well as speed. Hopefully these files get rolled into the next kernel-firmware RPM, as they should be...


Note You need to log in before you can comment on or make changes to this bug.