Bug 1069546 - [abrt] virt-viewer: g_slice_free1(): remote-viewer killed by SIGABRT
Summary: [abrt] virt-viewer: g_slice_free1(): remote-viewer killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spice-gtk
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marc-Andre Lureau
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2d5c42e14123e7935e18702c741...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 09:18 UTC by David Jaša
Modified: 2014-03-15 15:08 UTC (History)
8 users (show)

Fixed In Version: spice-gtk-0.23-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-15 15:08:23 UTC
Type: ---


Attachments (Terms of Use)
backtrace (37.22 KB, text/plain)
2014-02-25 09:31 UTC, David Jaša
no flags Details

Description David Jaša 2014-02-25 09:18:48 UTC
Version-Release number of selected component:
virt-viewer-0.5.7-2.fc20

Additional info:
reporter:       libreport-2.1.12
backtrace_rating: 4
cmdline:        remote-viewer --spice-controller
crash_function: g_slice_free1
executable:     /usr/bin/remote-viewer
kernel:         3.13.3-201.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 g_slice_free1 at gslice.c:1097
 #3 iter_remove_or_steal at ghash.c:787
 #4 clear_surfaces at /lib64/libspice-client-glib-2.0.so.8
 #5 spice_display_channel_finalize at /lib64/libspice-client-glib-2.0.so.8
 #7 spice_channel_delayed_unref at /lib64/libspice-client-glib-2.0.so.8
 #12 gtk_main at gtkmain.c:1158

Comment 1 David Jaša 2014-02-25 09:31:30 UTC
Created attachment 867310 [details]
backtrace

abrt failed to attach bt so attaching it manually.

Comment 2 Daniel Berrangé 2014-02-25 10:12:55 UTC
Reassigning to SPICE based on the stack trace.

Comment 3 Marc-Andre Lureau 2014-02-25 10:23:16 UTC
David, any chance you know how to reproduce?

Comment 4 Marc-Andre Lureau 2014-02-25 10:44:53 UTC
nevermind, the reason is pretty obvious, sending a patch

Comment 5 David Jaša 2014-02-25 10:48:29 UTC
Unfortunately no, I only noticed abrt report 4 days after actual crash. I can only get from the report that the client was launched from RHEV portal (CLI: remote-viewer --spice-controller) but that's just it...

Comment 6 Fedora Update System 2014-02-26 10:22:09 UTC
spice-gtk-0.23-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spice-gtk-0.23-2.fc20

Comment 7 Fedora Update System 2014-02-28 18:35:07 UTC
Package spice-gtk-0.23-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-gtk-0.23-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3210/spice-gtk-0.23-2.fc20
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-03-15 15:08:23 UTC
spice-gtk-0.23-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.