Bug 1069618 - fence_apc does not work with APC AP8965 with SSH [NEEDINFO]
Summary: fence_apc does not work with APC AP8965 with SSH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents
Version: 6.5
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 1055424 1070297 1092730 1116990
TreeView+ depends on / blocked
 
Reported: 2014-02-25 12:08 UTC by Tony Stocker
Modified: 2014-10-14 07:49 UTC (History)
9 users (show)

Fixed In Version: fence-agents-3.1.5-40.el6
Doc Type: Bug Fix
Doc Text:
Previously, the fence_apc program was hard-coded with SSH1 connectivity. As a consequence, fence-agents was unable to connect to power distribution units that require SSH2 connectivity. This update introduces the "--ssh-options" option, which makes it possible to specify SSH connectivity options in fence-agents. Thus, all fencing agents that support SSH can now be adjusted to meet the SSH requirements of the fencing device.
Clone Of:
: 1092730 1116990 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:49:24 UTC
Target Upstream Version:
slevine: needinfo? (rmccabe)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1562 normal SHIPPED_LIVE fence-agents bug fix update 2014-10-14 01:27:47 UTC

Description Tony Stocker 2014-02-25 12:08:07 UTC
Description of problem:
The version of the fence-agents does not work with the newer APC AP8965 PDU strips as these strips seem to require SSH 2 connectivity, despite their GUI interface which seems to indicate that they only support version 1.

Version-Release number of selected component (if applicable):
fence-agents-3.1.5-35.el6_5.3.x86_64

How reproducible:
Attempt to use fence_apc to access PDU

Steps to Reproduce:
1. Use fence_apc with ssh option like so:
fence_apc --ssh --ip=hydra-2-pdu1 --plug=1 --username=apc --password=apc --action=status

Actual results:
Unable to connect/login to fencing device

Expected results:
Status: ON

Additional info:
It appears that the version is hard coded in the fence_apc program, on my copy it is line 232 containing this entry:
options["ssh_options"] = "-1 -c blowfish"
If I modify this entry to be this:
options["ssh_options"] = "-2"
OR simply comment out the line entirely, then the script works as expected and I get the expected result.

Comment 2 Marek Grac 2014-02-26 14:25:13 UTC
Thanks for a report.

Upstream version already has --ssh-options, so this should be an easy fix.

Comment 12 errata-xmlrpc 2014-10-14 07:49:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1562.html


Note You need to log in before you can comment on or make changes to this bug.