Bug 1069658 - gracefully warn about unsupported upgrade from legacy releases
Summary: gracefully warn about unsupported upgrade from legacy releases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Petr Beňas
URL:
Whiteboard: integration
Depends On: 1054080
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-25 13:28 UTC by Sandro Bonazzola
Modified: 2015-01-04 23:05 UTC (History)
13 users (show)

Fixed In Version: av2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1054080
Environment:
Last Closed: 2014-06-12 14:05:49 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23664 None None None Never
oVirt gerrit 23665 None None None Never

Description Sandro Bonazzola 2014-02-25 13:28:09 UTC
+++ This bug was initially created as a clone of Bug #1054080 +++

Upgrading to 3.4.0 is supported only from 3.3.z.
Add checks for gracefully warn about unsupported upgrade from legacy releases.

--- Additional comment from Sandro Bonazzola on 2014-01-24 09:24:20 EST ---

Upgrade to 3.4.0 is allowed only from 3.3.z.

Avoid to pull in a version of ovirt-engine-setup that will
need to be downgraded in order to allow the upgrade
from a legacy version.

same will be for 3.5.0, upgrade will be allowed only from 3.4.0.

--- Additional comment from Sandro Bonazzola on 2014-01-24 09:24:40 EST ---

Upgrade to 3.4.0 is allowed only from 3.3.z.

Avoid to pull in a version of ovirt-engine-setup that will
need to be downgraded in order to allow the upgrade
from a legacy version.

same will be for 3.5.0, upgrade will be allowed only from 3.4.z.

--- Additional comment from Sandro Bonazzola on 2014-02-10 11:20:42 EST ---

(In reply to Sandro Bonazzola from comment #2)

> same will be for 3.5.0, upgrade will be allowed only from 3.4.z.

Requiring only >=3.3.2 for now: it may be possible that we'll be able to support upgrading from 3.3.2 to 3.5.0.

merged on master, pending merge on 3.4 branch

--- Additional comment from Sandro Bonazzola on 2014-02-19 07:27:15 EST ---

This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

--- Additional comment from Tareq Alayan on 2014-02-25 07:53:47 EST ---

Is this possible to upgrade from 33 downsrtream to upstream? 

i think that this fix should be in downstream?

--- Additional comment from Sandro Bonazzola on 2014-02-25 07:57:53 EST ---

Tareq, I think you'll have to wait for next downstream build.

--- Additional comment from Tareq Alayan on 2014-02-25 08:11:11 EST ---

Can you change fixed in field?

--- Additional comment from Sandro Bonazzola on 2014-02-25 08:22:34 EST ---

(In reply to Tareq Alayan from comment #7)
> Can you change fixed in field?

this is an oVirt bug, if you need to test it on RHEV I'll clone this.

Comment 1 Sandro Bonazzola 2014-02-25 13:29:04 UTC
Need downstream build to be verified on upgrade from a previous rhev-m version.

Comment 2 Petr Beňas 2014-03-13 13:47:10 UTC
Error: rhevm-setup-plugin-ovirt-engine conflicts with rhevm-3.2.6-0.50.el6ev.noarch
Error: Package: rhevm-setup-plugin-ovirt-engine-3.4.0-0.4.master.el6ev.noarch (rhevm34)
           Requires: rhevm >= 3.3.1
           Installed: rhevm-3.2.6-0.50.el6ev.noarch (@rhevm32)
               rhevm = 3.2.6-0.50.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 3 Itamar Heim 2014-06-12 14:05:49 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.