Bug 1069691 (JON3-25, PRODMGT-368) - DomainDeployments should be managed in a single menu option in domain mode
Summary: DomainDeployments should be managed in a single menu option in domain mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: JON3-25, PRODMGT-368
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR01
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
: 1100247 (view as bug list)
Depends On: 1104818 1108869 1109272
Blocks: 889250
TreeView+ depends on / blocked
 
Reported: 2014-02-25 14:19 UTC by Heiko W. Rupp
Modified: 2015-11-02 00:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:04:39 UTC
Type: Feature Request


Attachments (Terms of Use)
DomainDeployments (440.82 KB, image/png)
2014-06-03 20:58 UTC, Viet Nguyen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 889250 None None None Never
Red Hat Bugzilla 1069545 None None None Never
Red Hat Bugzilla 1069687 None None None Never
Red Hat One Jira Issue Tracker JON3-25 Major Verified DomainDeployments should be manage in a single menu option in domain mode [PRODMGT-368] 2016-03-03 18:05:01 UTC
Red Hat One Jira Issue Tracker PRODMGT-368 Major Closed DomainDeployments should be manage in a single menu option in domain mode 2016-03-03 18:05:01 UTC

Internal Links: 889250 1069545 1069687

Description Heiko W. Rupp 2014-02-25 14:19:54 UTC
Current set up to deploy content is confusing for some users - we should make it easier.

Users would like to deploy their files direct to a Deployment Repository or Content Repository with an option to distribute it to the desired server-groups without duplicated menus (like duplicated ServerGroups and DomainDeployments in host and domain controllers). Also, users would like an easy way to find which ServerGroups the file was deployed by showing it when clicking in the deployment file.
The EAP 6 names should be kept, like Manage Deployments, Content Repository, Available Deployment Content, and others.

Comment 1 Libor Zoubek 2014-05-22 13:46:07 UTC
*** Bug 1100247 has been marked as a duplicate of this bug. ***

Comment 2 Heiko W. Rupp 2014-05-30 15:30:02 UTC
merged to master in d3c6251b5f8aebf1ad4c24b703e3f1adffe338eb

Comment 3 JBoss JIRA Server 2014-05-30 15:30:25 UTC
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-25 to Resolved

Comment 6 Viet Nguyen 2014-06-03 20:56:38 UTC
I now can manage Server Group assignment for deployments.  Does it make sense to give users the ability to add/upload new war/ear directly from DomainDeployments?  It's counterintuitive to only be able to manage group assignment here and have to go to another place to upload my war/ear.  See attachment.

Comment 7 Viet Nguyen 2014-06-03 20:58:29 UTC
Created attachment 901907 [details]
DomainDeployments

Comment 9 Simeon Pinder 2014-07-31 15:52:16 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 10 JBoss JIRA Server 2014-08-15 23:06:36 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-25 to Reopened

Comment 11 JBoss JIRA Server 2014-10-10 16:54:57 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-25 to Resolved

Comment 13 Armine Hovsepyan 2014-10-14 09:18:28 UTC
marking as verified  - jira is resolved, no blocking issues


Note You need to log in before you can comment on or make changes to this bug.