Bug 106972 - Missing packages, missing option, hang
Missing packages, missing option, hang
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 22:52 EDT by Zenon Panoussis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 15:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2003-10-13 22:53:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031008

Description of problem:
Attempting to uppgrade from rh9 hangs forever after the package selection.

Fresh install lacks the option to select individual packages. 

Both upgrade and fresh install produce the following errors:

base references package redhat-logos which doesn't exist
base references package prctl which doesn't exist
core references package redhat-release which doesn't exist
core references package yaboot which doesn't exist
core references package efibootmgr which doesn't exist
core references package redhat-logos which doesn't exist
core references package elilo which doesn't exist
development-tools references package dev86 which doesn't exist
network-server references package pxe which doesn't exist

I was attempting a very minimal install; choosing more groups will probably
return more errors.

Finally, the installation hung forever in step preinstallconfig after the
message "no pcic controller detected". 

I should mention that both rh9 and severn-1 installed on the same machine
without any problems. Severn-3, turns out impossible to install, so for my part
this is a show-stopper.

The machine is a Siemens PII, full details on request.

How reproducible:
Always

Steps to Reproduce:
1a. Install rh9
2a. Attempt to upgrade to severn-3

1b. Attempt to install severn-3
Comment 1 Bill Nottingham 2003-10-14 01:05:20 EDT
Package stuff is cleaned up.
Comment 2 Bill Nottingham 2003-10-14 01:05:44 EDT
(i.e., will be fixed in future trees.)

As to the hang, that *may* be kernel related.
Comment 3 Zenon Panoussis 2003-10-14 07:09:58 EDT
Can you suggest some way to figure whether it is indeed kernel-related or not?
Comment 4 Jeremy Katz 2003-10-14 17:06:21 EDT
How does it hang?  Are there any messages on tty4?  Can you still use the shell
on tty2?
Comment 5 Zenon Panoussis 2003-10-14 18:57:26 EDT
Installation failure:
I tried a fresh install again, and this time it suceeded. Yesterday I did it
over FTP, today over NFS. No, there was nothing wrong with the FTP connection
yesterday; I checked. Also, the NFS distribution came from the same FTP server
that served yesterday's failed install; if files had been missing on it, they
would have been missing from both installations. 

Thus, either something is wrong with the FTP procedure only (hard to imagine;
apart from the access method everything should be the same between FTP and NFS),
or we have to ascribe this to the Inexplicable Whims of the Computing Gods and
then just forget it. 

Missing packages and inability to select individual packages:
Those parts of the bug remain. 

Comment 6 Jeremy Katz 2003-10-15 15:13:51 EDT
The missing packages bits aren't bugs, it's just anaconda being verbose. 
Individual package selection isn't coming back, there are several bugs against
beta1 about this.

Note You need to log in before you can comment on or make changes to this bug.