Bug 106973 - synaptics PS2 mouse driver doesn't like APM
synaptics PS2 mouse driver doesn't like APM
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 23:01 EDT by Dan Berger
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:14:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Berger 2003-10-13 23:01:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Galeon/1.3.9

Description of problem:
On my dell Insprion 4150 the onboard pointing device is a synaptics
touchpad/point stick combo.  While trying to get the latest test kernel happy, I
discovered that the (new?) synaptics driver doesn't like APM - suspending the
machine produces a message about failing to attach the driver, and on resume,
any touch of the pad produces "lost sync at packet 0" messages.

(Yes, I know ACPI is the "one true way" for power management - only problem is
it doesn't work on any hardware I've encountered - which makes it rather
useless...) 

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test7.1.52

How reproducible:
Always

Steps to Reproduce:
1. boot the kernel with acpi disabled (acpi=off)
2. suspend the machine 
3. resume the machine
    

Additional info:
Comment 1 Behdad Esfahbod 2003-11-05 04:54:28 EST
I get the same error since around the same kernel from Arjan whenever
I boot that kernel.  I'm pretty sure it was introduced around that
version.  It was working with .4x.
Comment 2 Dave Jones 2004-10-29 23:54:27 EDT
fixed in current kernels ?
Comment 3 Dan Berger 2004-10-30 12:25:42 EDT
I no longer have the hardware I observed this bug on - so I can't say.

Note You need to log in before you can comment on or make changes to this bug.