Bug 106974 - usb keyboard and mouse support missing from kernel configuration
Summary: usb keyboard and mouse support missing from kernel configuration
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-14 03:11 UTC by Dan Berger
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 21:15:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Berger 2003-10-14 03:11:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Galeon/1.3.9

Description of problem:
the following two config entries are unset in the 2.6 test RPMS:

CONFIG_USB_KBD
CONFIG_USB_MOUSE

as such, usb mice and keyboards aren't recognized.

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test7.1.52

How reproducible:
Always

Steps to Reproduce:
1. boot the test kernel
2. attempt to use a usb keyboard or mouse

Additional info:

Comment 1 Bill Nottingham 2003-10-14 05:06:23 UTC
You should use the HID keyboard and mouse drivers, AFIAIK.

Comment 2 Dan Berger 2003-10-14 06:23:28 UTC
I read that in the config help - but couldn't find any *useful* pointers on how
to do so.  The end result was that without those two config modules built, usb
keyboard and mouse wouldn't work at all - with them, they did.

If you have any pointers on how to make a USB keyboard and/or mouse work without
building those modules, I'm all ears.

Comment 3 Dan Berger 2003-10-22 00:48:31 UTC
At this point I'm still rebuilding the kernel to include those two drivers - but
if there's a better way, I'd really like to know.  Any comment?  Does anyone
have a USB keyboard and/or mouse working with the binary kernel RPMS (i.e.
without the keyboard and mouse boot HID drivers)?

Comment 4 Ralf Ertzinger 2003-10-22 12:48:55 UTC
It may be that your problems arise from the fact that the USB UHCI/OHCI drivers
have a different name under 2.6.

On my system I had to use usb-uhci under 2.4.
The correct driver for 2.6 is uhci_hcd.

Note that changing the name in /etc/modules.conf did not work, at least for me.
I am manually loading the driver in /etc/rc.local.

Comment 5 Dan Berger 2003-10-22 15:11:34 UTC
Thanks, but the problem isn't the host adaptor - that's just fine (I made the
change in /etc/modprobe.conf - note the new name - the new modutils doesn't look
at modules.conf - and all was good) - the problem was that usbmouse.ko couldn't
be found (cause it wasn't built and installed) by modprobe.

The configuration help seems to suggest there's a newer better more pure way to
use usb input devices, but I haven't been able to find anything on how that
magic is supposed to work (other than to rebuild the kernel and include usbmouse
and usbkbd as modules).


Comment 6 Dan Berger 2003-10-22 21:15:28 UTC
Ok - fixed it - error between keyboard and chair.  Closing.


Note You need to log in before you can comment on or make changes to this bug.