Bug 106979 - browser closed when trying to load java applet
browser closed when trying to load java applet
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
chat.yahoo.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 00:03 EDT by Don Russell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 12:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2003-10-14 00:03:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
I installed Sun JRE 1.4.2
Then I added the link to point to the plugin:
as root, from directory /usr/lib/mozilla-1.4.1/plugins
I entered this command...
ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/libjavaplugin_oji.so .

I then tried to go to my network switch (HP2424M) which runs a java applet
interface... I saw the message saying Java Applet loading.... then nothing... no
further page activity.

I then wento chat.yahoo.com and tried logging in.
When it got to the point of loading the chat applet, the browser suddenly closed.


Version-Release number of selected component (if applicable):
mozilla 1.4.1

How reproducible:
Always

Steps to Reproduce:
1. Try to go a web page with a java aplet
2.
3.
    

Actual Results:  Java applet does not run, browser may crash

Expected Results:  I expect the java aplet to run and be able to use the web page.

Additional info:

I understand you can't actually include the jre, but once it is installed it
should work...
Comment 1 Michael Young 2003-10-14 08:05:27 EDT
I have the link in /usr/lib/mozilla/plugins, and can view java applets
successfully, so maybe it is something you have done wrong (my mozilla is 1.4.1-7).
Comment 2 Don Russell 2003-10-14 20:54:47 EDT
Well, oddly enough, I tried going to my switch (http://switch address) again....
there was a long delay which made me think it wasn't working.... and then Poof!
it started up...

The only thing I can think of is that I did not properly shutdown/restart
Mozilla after I defined the link. (Maybe another window was still open, but
minimized, I THOUGHT I did... and since then and now I've rebooted the machine
too...

So, the good news ... it's working now.... though the delay was several (5-10)
seconds....

Closing/restarting the browser now... my switch page comes up very quickly...
something about that first time I guess.

Don Russell
Comment 3 Christopher Blizzard 2003-10-16 12:55:47 EDT
OK, marking worksforme.

Note You need to log in before you can comment on or make changes to this bug.