Bug 1069790 - php-fpm subpackage doesn't create /var/lib/php/session/
php-fpm subpackage doesn't create /var/lib/php/session/
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-25 11:38 EST by Clayton Louden
Modified: 2014-03-15 11:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: php-5.5.10-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-08 23:40:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clayton Louden 2014-02-25 11:38:01 EST
Description of problem:
I installed nginx and php-fpm to run an owncloud instance

# yum install nginx php-fpm

But owncloud is pretty unhappy, because it can't create php sessions in '/var/lib/php/session' simply because the directory doesn't exist. As soon as I do

# mkdir /var/lib/php/session
# chown root:apache /var/lib/php/session/
# chmod 770 /var/lib/php/session/
# systemctl restart nginx.service

everything runs perfectly well. I'm not sure, if this is due to a missing dependency and 'yum install php-fpm' is actually supposed to pull the php package as well (though I doubt that) or simply, because the subpackage doesn't own /var/lib/php/session/.

Version-Release number of selected component (if applicable):
php-fpm-5.5.9-1.fc20.x86_64

How reproducible:
always
Comment 1 Remi Collet 2014-02-26 03:37:38 EST
php-fpm should provide /var/lib/php/session and also /var/lib/php/wsdlcache
Comment 2 Fedora Update System 2014-03-06 03:10:20 EST
php-5.5.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-5.5.10-1.fc20
Comment 3 Fedora Update System 2014-03-06 03:10:30 EST
php-5.5.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/php-5.5.10-1.fc19
Comment 4 Fedora Update System 2014-03-07 01:31:53 EST
Package php-5.5.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-5.5.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3534/php-5.5.10-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-03-08 23:40:38 EST
php-5.5.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2014-03-15 11:00:46 EDT
php-5.5.10-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.