Bug 1069850 - [GSS] (6.3.0) Prevent NullPointerException in JDR CommandLineMain
Summary: [GSS] (6.3.0) Prevent NullPointerException in JDR CommandLineMain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JDR
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Brad Maxwell
QA Contact:
Scott Mumford
URL:
Whiteboard:
Depends On:
Blocks: 1069894
TreeView+ depends on / blocked
 
Reported: 2014-02-25 19:02 UTC by Brad Maxwell
Modified: 2018-12-04 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, an NullPointerException would be thrown whenever an exception was thrown from JDR CommandLineMain. This issue has been corrected in this release.
Clone Of:
: 1069894 (view as bug list)
Environment:
Last Closed: 2014-06-28 15:32:03 UTC
Type: Bug
smumford: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-3016 Major Resolved Prevent NullPointerException in JDR CommandLineMain 2014-08-04 19:22:13 UTC

Description Brad Maxwell 2014-02-25 19:02:38 UTC
If an exception is throw, it leads to a null pointer: 

Failed to complete the JDR report: JBAS013352: Zipfile could not be created.
Exception in thread "main" java.lang.NullPointerException
        at org.jboss.as.jdr.CommandLineMain.main(CommandLineMain.java:96)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:613)
        at org.jboss.modules.Module.run(Module.java:292)
        at org.jboss.modules.Main.main(Main.java:455)

Comment 1 JBoss JIRA Server 2014-02-25 19:22:13 UTC
Brad Maxwell <bmaxwell@redhat.com> updated the status of jira WFLY-3016 to Coding In Progress

Comment 2 Brad Maxwell 2014-02-25 19:24:29 UTC
Move the prints into the try { } since if standaloneCollect throws an exception, the response object will be null

Comment 4 Petr Kremensky 2014-03-10 09:14:21 UTC
Verified on EAP 6.3.0.DR2.

Comment 5 Scott Mumford 2014-04-24 05:13:30 UTC
Brad, you say in comment 2 "...since if standaloneCollect throws an exception, the response object will be null".

I was wondering if you could clarify if the response object being null was the cause of, or the solution to, the NPE problem.


Note You need to log in before you can comment on or make changes to this bug.