Bug 1069867 - don't pull in kernel from libseccomp
Summary: don't pull in kernel from libseccomp
Keywords:
Status: CLOSED DUPLICATE of bug 1065572
Alias: None
Product: Fedora
Classification: Fedora
Component: libseccomp
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Moore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 19:53 UTC by Lennart Poettering
Modified: 2014-02-25 20:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 20:08:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Lennart Poettering 2014-02-25 19:53:27 UTC
libseccomp is now a dependency of systemd. When one installs a container tree based on Fedora this means libseccomp and all of its depndencies are pulled in. This includes the dependency "kernel >= 3.5", which means a kernel is pulled into the container tree which however really isn't needed there.

The dependency should probably be simply dropped, or turned into a "Conflicts: kernel < 3.5" or so (though i see very little point in that, the libray should fail cleanly anyway, right?), so that we can set up containers without pulling in kernel.rpm again.

Comment 1 Lennart Poettering 2014-02-25 19:54:37 UTC
$ rpm -qa libseccomp
libseccomp-2.1.0-1.fc20.x86_64

$ rpm -q --requires libseccomp
/sbin/ldconfig
/sbin/ldconfig
kernel >= 3.5  ←←←←←←
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
rpmlib(PayloadIsXz) <= 5.2-1

Comment 2 Paul Moore 2014-02-25 20:08:32 UTC

*** This bug has been marked as a duplicate of bug 1065572 ***


Note You need to log in before you can comment on or make changes to this bug.