Bug 106987 - named assertion fails in ifiter_ioctl.c at 218
named assertion fails in ifiter_ioctl.c at 218
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
http://liste.ferrara.linux.it/archive...
:
: 106988 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 03:47 EDT by Jacek Pliszka
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-19 00:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pliszka 2003-10-14 03:47:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030708

Description of problem:
During 
service network restart

named dies with the following information in /var/log/messages:

Oct 12 22:01:47 server named[13996]: ifiter_ioctl.c:218: REQUIRE(iter->pos <
(unsigned int) iter->ifc.ifc_len) failed
Oct 12 22:01:47 server named[13996]: exiting (due to assertion failure)


Version-Release number of selected component (if applicable):
bind-9.2.1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.run named
2.restart network:  service network restart
3.
    

Actual Results:  Nothing but I want to report the asssertion failure which,
acording tio URL
I sent, is DoS hole fixed in 9.2.2

Additional info:
Comment 1 Daniel Walsh 2003-10-19 00:11:40 EDT
Fix available in RawHide and I believe as an errata.
Comment 2 Daniel Walsh 2003-10-19 00:12:43 EDT
*** Bug 106988 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.