Bug 1069996 - [abrt] dnf: repo.py:312:start:AttributeError: 'NoneType' object has no attribute 'start'
Summary: [abrt] dnf: repo.py:312:start:AttributeError: 'NoneType' object has no attrib...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:cd6916b7afc4ecffbd1fe51388a...
Keywords:
: 1070826 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 03:59 UTC by sangu
Modified: 2014-11-06 15:43 UTC (History)
59 users (show)

Fixed In Version: dnf-0.4.16-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 18:37:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.45 KB, text/plain)
2014-02-26 04:00 UTC, sangu
no flags Details
File: environ (72 bytes, text/plain)
2014-02-26 04:00 UTC, sangu
no flags Details

Description sangu 2014-02-26 03:59:57 UTC
Description of problem:
While dnf services work

Version-Release number of selected component:
dnf-0.4.15-1.fc21

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.14.0-0.rc4.git0.1.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
repo.py:312:start:AttributeError: 'NoneType' object has no attribute 'start'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 124, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1459, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 852, in run
    self.base.fill_sack() # performs the md sync
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 213, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 120, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 548, in load
    self._handle_load(handle)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 349, in _handle_load
    self._md_pload.start(self.name)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 312, in start
    self.progress.start(1, 1)
AttributeError: 'NoneType' object has no attribute 'start'

Local variables in innermost frame:
text: u'RPM Fusion for Fedora Rawhide - Free'
self: <dnf.repo.MDPayload object at 0x22477d0>

Comment 1 sangu 2014-02-26 04:00:01 UTC
Created attachment 867729 [details]
File: backtrace

Comment 2 sangu 2014-02-26 04:00:03 UTC
Created attachment 867730 [details]
File: environ

Comment 3 Igor Gnatenko 2014-02-26 05:23:40 UTC
got this bug today

Comment 4 Ales Kozumplik 2014-02-26 08:37:31 UTC
reproducable from CLI:

$ dnf makecache &>output

Comment 5 Ales Kozumplik 2014-02-26 10:07:22 UTC
Fixed by 16ca933.

Comment 6 Fedora Update System 2014-02-26 13:54:27 UTC
dnf-0.4.16-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.16-2.fc20

Comment 7 Peter H. Jones 2014-02-27 05:12:45 UTC
Only needed to download and install dnf. python-dnf, available in the same build, was not needed.

Comment 8 Radek Holy 2014-02-27 15:34:36 UTC
*** Bug 1070826 has been marked as a duplicate of this bug. ***

Comment 9 ILMostro 2014-02-28 00:20:34 UTC
if it "works for you", go over to the "admin.fedoraproject.org" page (the link to the update) and leave karma for the package.

Comment 10 Paul Lipps 2014-02-28 14:44:41 UTC
Why is dnf crashing when I didn't execute it? I thought it's use was optional for Fedora 20?

Comment 11 Jan Zeleny 2014-02-28 15:34:18 UTC
If you have installed the package, it's possible that there is something running on the background, IIRC there is a daemon that runs on background and downloads metadata when necessary.

Comment 12 Fedora Update System 2014-02-28 18:37:34 UTC
dnf-0.4.16-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 M. Edward (Ed) Borasky 2014-03-01 00:27:09 UTC
(In reply to Paul Lipps from comment #10)
> Why is dnf crashing when I didn't execute it? I thought it's use was
> optional for Fedora 20?

I recently installed a system from the desktop live media. Anaconda is installed by default and anaconda has dnf as a dependency.

Comment 14 Paul Lipps 2014-03-01 00:49:29 UTC
Right. I never installed, nor attempted to execute it, yet I am notified to report bugs on it. It should only be in rawhide until it's ready for mainstream use. Some of us actually use Fedora as our everyday operating system rather than a Red Hat employee playground.

Comment 15 Wilbert Isaac Cortés González 2014-03-01 20:12:41 UTC
So this is a little bit annoying. This keeps happening on and on, even when I did the upgrade (by the way at this moment there's not any update/upgrade for dnf or for any other package, I did see an upgrade for dnf, I installed it, and nothing, it keeps happening).

EOF

Comment 16 randyzoch 2014-03-01 22:18:14 UTC
Even though this is listed as closed, it is still occurring.

Comment 17 csouth3 2014-03-01 23:20:02 UTC
This bug still occurs, several times daily with no apparent rhyme or reason.

Comment 18 Paul Lipps 2014-03-02 01:15:05 UTC
Yes this is still a problem after updating. Can someone please reopen this? I can just clone it as well, please advise.

Comment 19 Joseph Yaworski 2014-03-02 01:16:48 UTC
The update solved the problem for me. With all the other queries, it may deserve more investigation.

Comment 20 Michael Hampton 2014-03-02 01:22:57 UTC
I'm not seeing the problem, but I also restarted after applying the update (since I also got a kernel update). Affected users might want to try restarting the computer, or at least restarting systemd with systemctl daemon-reload or daemon-reexec.

Comment 21 Andre Robatino 2014-03-02 01:25:57 UTC
The version that's supposed to fix this (dnf-0.4.16-2.fc20) didn't go out in the push it was supposed to, but rather in the one after that (less than 12 hours ago). Anyone who thinks this isn't fixed, please double check which version you have.

Comment 22 Paul Lipps 2014-03-02 01:28:58 UTC
Ah I see yes I still have dnf-0.4.15-1.f20

Comment 23 Ales Kozumplik 2014-03-02 08:56:11 UTC
Hello, this bug occurs because dnf is updating its cache in the background. The version this is fixed in is 0.4.16. We release updates frequently so it is possible some of you only got 0.4.15 now.

Comment 24 csouth3 2014-03-02 18:52:39 UTC
For some reason I had to pull the latest update (0.4.16) from updates-testing (couldn't find it in stable even like 12 hours after it was supposedly pushed for some reason.) but yeah I can confirm that after doing that update this bug is fixed.
Thanks!


Note You need to log in before you can comment on or make changes to this bug.