Bug 1070028 - qemu-kvm flood with 'Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2'
Summary: qemu-kvm flood with 'Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_star...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 05:57 UTC by Xu Han
Modified: 2015-03-05 07:56 UTC (History)
10 users (show)

Fixed In Version: spice-0.12.4-7.el7
Doc Type: Bug Fix
Doc Text:
Under certain conditions, qemu-kvm logs would get flooded with "'Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2'" warnings. This warning has been changed to a debug which does not appear by default in the logs.
Clone Of:
Environment:
Last Closed: 2015-03-05 07:56:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0335 0 normal SHIPPED_LIVE spice bug fix and enhancement update 2015-03-05 12:23:09 UTC

Description Xu Han 2014-02-26 05:57:23 UTC
Description of problem:
qemu-kvm flood with 'Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2'

Version-Release number of selected component (if applicable):
spice-server-0.12.4-5.el7.x86_64
spice-glib-0.20-8.el7.x86_64
spice-gtk3-0.20-8.el7.x86_64
qemu-kvm-rhev-1.5.3-49.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. let spice monitor flushs frequently under text mode.
1.1. login text mode
# init 3
1.2. touch files on guest
# for ((i=0;i<5000;i++)); do touch `printf "%032d" $i`; done
1.3. list files name
# ls

Actual results:
qemu-kvm flood with:
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
(/usr/libexec/qemu-kvm:19159): Spice-Warning **: mjpeg_encoder.c:799:mjpeg_encoder_start_frame: unsupported format 2
...

Expected results:
should not generate so many messages.

Comment 2 Christophe Fergeau 2014-02-26 15:03:42 UTC
This probably does not deserve a spice_warning(), sent a patch to downgrade that log to spice_debug() which is not shown in logs by default
http://lists.freedesktop.org/archives/spice-devel/2014-February/016244.html

Comment 3 RHEL Program Management 2014-03-22 05:56:52 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 errata-xmlrpc 2015-03-05 07:56:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0335.html


Note You need to log in before you can comment on or make changes to this bug.