Bug 107018 - second session written with growisofs not visible if using udf
second session written with growisofs not visible if using udf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 08:38 EDT by Mirko Streckenbach
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 10:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mirko Streckenbach 2003-10-14 08:38:17 EDT
Description of problem:

If a dvd+rw is written with udf support, the second written session does
not become visible if the filesystem is mounted.

Version-Release number of selected component (if applicable):

dvd+rw-tools-5.13.4.7.4-1
mkisofs-2.01-0.a19.1
kernel-2.4.22-1.2088.nptl

How reproducible:

Create a filesystem with growisofs with -udf option, add a second session
using the same options.

Steps to Reproduce:

> touch first
> touch second
> growisofs -Z /dev/cdrom -r -J -udf first
> growisofs -M /dev/cdrom -r -J -udf -m second
> mount -tiso9660 /dev/cdrom /mnt/cdrom
> ls /mnt/cdrom
first
> umount /mnt/cdrom
> mount -tiso9660 -oro /dev/cdrom /mnt/cdrom
first  second

Actual results:

Only files from first session visible if written dvd is mounted with udf
filesystem

Expected results:

Files from both sessions visible regardless of filesystem type used for
mounting

Additional info:

DVD recorder is an Sony DVD RW DRU-510A with a DVD+RW media
Comment 1 Harald Hoyer 2003-10-24 10:22:02 EDT
Why do you use -tiso9660 and not -tudf?
Why don't you use "mkudffs"?
mkisofs -udf seems to be _alpha_ status...
       -udf   Include UDF support in the generated filesystem image.  UDF sup-
              port is currently in alpha status and for this reason, it is not
              possible  to  create  UDF  only images.  UDF data structures are
              currently coupled to the Joliet structures, so  there  are  many
              pitfalls  with  the  current implementation. There is no UID/GID
              support, there is no POSIX permission support, there is no  sup-
              port  for  symlinks.  Note that UDF wastes the space from sector
              ~20 to sector 256 at the beginning of the disk  in  addition  to
              the spcae needed for real UDF data structures.
Comment 2 Mirko Streckenbach 2003-10-24 14:46:16 EDT
Sorry, the steps to reproduce were wrong, correct is:

> touch first
> touch second
> growisofs -Z /dev/cdrom -r -J -udf first
> growisofs -M /dev/cdrom -r -J -udf -m second
> mount -tudf /dev/cdrom /mnt/cdrom
> ls /mnt/cdrom
first
> umount /mnt/cdrom
> mount -tiso9660 -oro /dev/cdrom /mnt/cdrom
first  second

I hope this makes the problem more clear.

BTW: I'm not sure this is an mkisofs problem, this could also be a mistake
in the udf filesystem driver.

>> Why do you use -tiso9660 and not -tudf?
See above.

>> Why don't you use "mkudffs"?
1. It does not seems to be Part of Fedora Linux.
2. mkisofs is used by growisofs of the dvd+rw-tools. There is not 
freedom of choice in this context.
3. mkudffs is hard to use for an "I just want my stuff burned" user.

>> mkisofs -udf seems to be _alpha_ status...
I'm aware of this. However, the dvd+rw-tools are currently the most convenient
way to incrementally write to an dvd+rw media. If one wants the written media
readble with windows, either -J or -udf is mandatory and -J is not available
with filenames >64 characters.
However, updfstab of kudzu set the filesystem type for cd-roms to "udf,iso9660"
so a non-root user is not able to mount an iso/udf disc as iso9660, making the
second session of the disc unreadable. We have >20 machines, so manually
correcting kudzu's behaviour is not an option.

If the included creation tools for udf are alpha, maybe udf should not be the
first option for mounting cd/dvds.
Comment 3 Harald Hoyer 2004-10-13 10:38:04 EDT
ok, looking at the whole thing... just do not use -udf for multiple
sessions... udf does not seem to be ... well, doing what it is
supposed to do... sorry..

Note You need to log in before you can comment on or make changes to this bug.