Bug 1070183 - FTBFS: cannot access '/builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64
Summary: FTBFS: cannot access '/builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk
Version: rawhide
Hardware: powerpc
OS: Linux
high
high
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-02-26 11:15 UTC by Karsten Hopp
Modified: 2014-03-06 12:55 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-03-06 12:55:25 UTC


Attachments (Terms of Use)
build.log (7.67 MB, text/plain)
2014-02-26 12:02 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2014-02-26 11:15:52 UTC
Description of problem:
WARNING: File /builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64/openjdk/build/linux-ppc64/hotspot/import/lib/sa-jdi.jar does not exist.
         The JDI binding for the Serviceability Agent will not be included in the build.
         Please check your access to
           /builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64/openjdk/build/linux-ppc64/hotspot/import/lib/sa-jdi.jar
         and/or check your value of ALT_HOTSPOT_IMPORT_PATH.

and later it aborts with a similar error:

########################################################################
##### Leaving jdk for target(s) sanity all docs images             #####
########################################################################
##### Build time 01:23:05 jdk for target(s) sanity all docs images #####
########################################################################
#-- Build times ----------
Target all_product_build
Start 2014-02-25 11:34:52
End   2014-02-25 13:23:08
00:12:58 corba
00:03:58 hotspot
00:02:39 jaxp
00:03:05 jaxws
01:23:05 jdk
00:02:31 langtools
01:48:16 TOTAL
-------------------------
make[1]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64/openjdk'
+ popd
RPM build errors:
++ pwd
+ chmod 644 /builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64/openjdk/build/linux-ppc64/j2sdk-image/lib/sa-jdi.jar
chmod: cannot access '/builddir/build/BUILD/java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.ppc64/openjdk/build/linux-ppc64/j2sdk-image/lib/sa-jdi.jar': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.ZPBNK2 (%build)
    Bad exit status from /var/tmp/rpm-tmp.ZPBNK2 (%build)

Version-Release number of selected component (if applicable):
java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21

How reproducible:


Steps to Reproduce:
1. ppc-koji build --scratch f21 java-1.7.0-openjdk-1.7.0.60-2.5.0.4.pre02.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1679319

Expected results:


Additional info:

Comment 1 Karsten Hopp 2014-02-26 12:02:01 UTC
Created attachment 867955 [details]
build.log

Comment 2 jiri vanek 2014-02-26 12:42:25 UTC
This is new after updating to ppc64 jit port.

Comment 3 Andrew John Hughes 2014-02-26 17:55:11 UTC
Well, yes Jiri, because of the way you cherry-picked changes rather than just pulling in the patch I sent you:

https://github.com/gnu-andrew/java-1.7.0-openjdk/commit/dd37b4a4a9c83667e468ccf0d4c3156a982fbc56

My own build went fine:

https://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1654419

I was wondering how you'd built the current version on ppc. Clearly, you haven't until now.

If you're going to alter my patches and claim them as your own, please don't assign bugs to me when the result doesn't work.

Comment 5 jiri vanek 2014-03-06 12:55:25 UTC
All builds passed, so should be fine.


Note You need to log in before you can comment on or make changes to this bug.