Bug 1070189 - PPC64 VMs shouldn't be suspended
Summary: PPC64 VMs shouldn't be suspended
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Vitor de Lima
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 11:26 UTC by Vitor de Lima
Modified: 2016-02-10 19:49 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:42:45 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24015 master MERGED webadmin: Prevent VM suspend in the ppc64 arch Never
oVirt gerrit 24016 master NEW core, engine: Prevent VM suspend in the ppc64 arch Never
oVirt gerrit 25069 ovirt-engine-3.4 ABANDONED webadmin: Prevent VM suspend in the ppc64 arch Never
oVirt gerrit 25074 ovirt-engine-3.4 ABANDONED core, engine: Prevent VM suspend in the ppc64 arch Never

Description Vitor de Lima 2014-02-26 11:26:50 UTC
Description of problem:
The QEMU for ppc64 does not support VM suspension yet, but the frontend still makes this option available for the end user.

Version-Release number of selected component (if applicable):
3.4beta3

How reproducible:
Always

Steps to Reproduce:
1. Configure a Data Center, Clusters, Storage, Host and a VM for the ppc64 architecture
2. Run the previously configured VM
3. Suspend the VM
4. Unsuspend it

Actual results:
The VM returns frozen and QEMU may crash after a while in this state.

Expected results:
The frontend should block the user from doing the VM suspension.

Additional info:

Comment 1 Itamar Heim 2014-03-02 05:42:09 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:28:21 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Michal Skrivanek 2014-05-07 13:09:42 UTC
can we get the 24016 merged on master so this can be closed at least for 3.5? It's approved, there's just a merge conflict which needs to be resolved

Comment 4 Sandro Bonazzola 2014-05-08 13:55:57 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 5 Vitor de Lima 2014-10-08 17:07:14 UTC
Both patches were merged in master branch.

Comment 6 Sandro Bonazzola 2014-10-17 12:42:45 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.