Bug 1070246 - ImageMagick display doesn't show file selector dialog
Summary: ImageMagick display doesn't show file selector dialog
Keywords:
Status: CLOSED DUPLICATE of bug 1043686
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ImageMagick
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 7.0
Assignee: Jan Horak
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 13:35 UTC by Martin
Modified: 2020-01-06 14:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-06 14:23:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin 2014-02-26 13:35:15 UTC
Description of problem:
ImageMagick display doesn't show file selector dialog.

Version-Release number of selected component (if applicable):
ImageMagick-6.7.8.9-9.el7.x86_64

How reproducible:
always

Steps to Reproduce:
Run: display

Actual results:
display: color is not known to server `FOREGROUND': No such file or directory @ error/xwindow.c/XGetPixelPacket/3064. 

Expected results:
Open a file selector window to load a file instead.

Comment 2 Benjamin Tissoires 2014-02-27 19:39:44 UTC
Moving it to 7.1 as it does not qualify as blocker

Comment 3 Benjamin Tissoires 2014-02-27 19:43:42 UTC
I am not sure it is a real bug. To me, it seems more to be the new default behavior: under either F19 or F20, the command "display" does not show the popup anymore.

Also, I do not have the error you mentioned Martin. Can you confirm that you still see "display: color is not known to server `FOREGROUND': No such file or directory @ error/xwindow.c/XGetPixelPacket/3064."

Comment 6 Alan 2014-10-28 09:20:41 UTC
I see the same problem when I try to use display with any file.  Not sure what's causing it.
Graphics Magic returns a similar error but does pop up a window:
gm display: Color is not known to server (FOREGROUND) [No such file or directory].
gm display: Color is not known to server (BACKGROUND) [No such file or directory].

Comment 9 Orion Poplawski 2015-06-30 16:23:12 UTC
We see the same error under KDE:

display: color is not know to server `FOREGROUND': No such file or directory @ error/xwindow.c/XGetPixelPacket/3064.

Agree that file selector behavior is probably an upstream change.

Comment 10 Orion Poplawski 2015-06-30 16:23:42 UTC
ImageMagick-6.7.8.9-10.el7.x86_64

Comment 11 Orion Poplawski 2015-11-04 20:28:49 UTC
This is a duplicate of 1043686

Comment 12 Tomas Popela 2020-01-06 14:23:53 UTC

*** This bug has been marked as a duplicate of bug 1043686 ***


Note You need to log in before you can comment on or make changes to this bug.