Bug 107025 - Cannot use font replacement table to change the GUI font
Cannot use font replacement table to change the GUI font
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2003-10-14 10:34 EDT by Nigel Smith
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-27 11:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nigel Smith 2003-10-14 10:34:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
Cannot use the font replacement table to change the GUI font to match the rest
of the system. This spoils the look-and-feel integration with the rest of the
gnome desktop.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start any OO application
2. Go to Tools -> Options -> OppenOffice.org -> Fonts
3. Check 'Apply Replacement Table'
4. Add a mapping from 'Interface User' to 'Luxi Serif' and select 'Always' and
5. Click OK and restart the application.


Actual Results:  GUI font is still Bitstream Vera Sans.

Expected Results:  GUI font should be Luxi Sans

Additional info:
Comment 1 Miklos Muller 2003-10-15 10:50:41 EDT
same here with 'Interface User -> Bitstream Vera Sans'.
Tried also with 'Andale Sans UI -> Bitstream Vera Sans' as suggested on
Comment 2 Dan Williams 2003-10-15 11:17:40 EDT
Hmm, works for me with 1.1.0-2 on Fedora updated from rawhide.  When launched
there was 1 existing remapping, from Andale Sans UI -> Luxi Sans.  Changing that
from Luxi Sans to Courier and clicking OK made the interface look like ass, but
it did do the replacement.  Did either of you have anything in your replacement
table before you tried changing it?

It might be an issue with upgraded 1.0.2 versions -> 1.1.0, did either of you
install OOo 1.1.0 over top of 1.0.2?
Comment 3 Nigel Smith 2003-10-15 11:32:40 EDT
I did a clean install of test3 from the isos (10/10/03) on a spare partition.
I'll try to map Andale Sans when I get home. I'll also try openoffice from
Rawhide, see if that makes a difference.
Comment 4 Miklos Muller 2003-10-15 11:56:59 EDT
> It might be an issue with upgraded 1.0.2 versions -> 1.1.0, did either of you
> install OOo 1.1.0 over top of 1.0.2?

Clean install here too, so the issue is the opposite i think.
Comment 5 Nigel Smith 2003-10-15 13:43:57 EDT
Ok, I had a play and I think I know what the problem is. On a clean install of
OpenOffice no default mapping exists from Andale Sans UI to Luxi Sans, in fact
Andale Sans UI doesn't appear in the drop down list any more, so it appears
openoffice falls back to Bitstream Vera Sans for the GUI. You can, however, type
'Andale Sans UI' manually into the first box and map this to 'Luxi Sans'. This
appears to work fine. Mapping to the font 'Interface User' is still broken.

Comment 6 Miklos Muller 2003-10-15 14:48:59 EDT
Heh, I was in the belief that I'm looking at Luxi Sans fonts.
Of course I saw no difference When I mapped 'Andale Sans UI'
to 'Bitstream Vera Sans' :)
Comment 7 Dan Williams 2003-11-06 08:22:29 EST
Can you test this again iwth 1.1.0-6?  Instead of Andale Sans UI
though, the default font for UI is now Luxi Sans, unless you are
Russion in which case it is Nimbus Sans L.
Comment 8 Miklos Muller 2003-11-06 13:59:32 EST
"Luxi Sans -> Anything" works, the user interface font changes
immediately. However I would still rather expect "Interface User ->
Something else" as the real solution to change the user interface
font. BTW wouldn't it be more user friendly to call that font "User
Interface" instead?
Comment 9 Nigel Smith 2003-11-10 06:52:06 EST
Yep, I agree with the above. Bit of a pain if you change your theme
font, you can no longer use Luxi Sans in your docs. Shouldn't OO just
pick up the font from the current theme the same way as it picks up
the colours? Just a thought.
Comment 10 Dan Williams 2003-11-10 09:05:04 EST
Technically, yes, OOo _does_ pick up the current font when you check
Tools->Options->Accessibility->"Use system font".  The problem here is
interaction with Fontconfig.  Because it doesn't interface very well
(if at all) with fontconfig right now, OOo has no idea of the current
system font in some situations.

For example, what's your current system default font?  On a vanilla
isntall of Fedora, its "Sans".  Well, guess what?  There _is_ no Sans
font anywhere, because Sans is a fontconfig meta-font that may be a
couple of different fonts for different character ranges.  Its not a
single font file somewhere, like OOo expects.  You can enable the Use
System Font option, but your mileage may vary...

That said, I hope to integrate the Ximian fontconfig patches sometime
soon, and then some of this pain will go away, but not all of it...
Comment 11 Nigel Smith 2003-11-10 09:26:11 EST
Cool, didn't know about the "Use system font" option. Seems to work
fine (unless, as you say, the system font is 'Sans').

Many thanks.
Comment 12 Dan Williams 2004-02-27 11:43:56 EST

Note You need to log in before you can comment on or make changes to this bug.