Bug 1070265 - Listing templates takes noticeable amount of time, while listing many more VMs is prompt
Summary: Listing templates takes noticeable amount of time, while listing many more VM...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.3.2
Assignee: Omer Frenkel
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On: 1064907
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 14:04 UTC by rhev-integ
Modified: 2019-04-28 09:20 UTC (History)
13 users (show)

Fixed In Version: is35
Doc Type: Bug Fix
Doc Text:
Previously, having a large number of virtual machines and templates in a Red Hat Enterprise Virtualization environment would cause queries for listing those virtual machines and templates to take a long time to complete. Now, the search mechanism has been revised so that the information on disks for each template is not retrieved, thereby shortening the time required to build the list and greatly increasing the speed of the query.
Clone Of: 1064907
Environment:
Last Closed: 2014-04-09 17:56:08 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0384 normal SHIPPED_LIVE rhevm 3.3.2 bug fix update 2014-04-09 21:52:20 UTC
oVirt gerrit 24996 None None None Never
oVirt gerrit 25035 None None None Never
oVirt gerrit 25138 None None None Never

Comment 2 Ilanit Stein 2014-03-23 10:14:38 UTC
Verified on rhevm-3.3.2-0.49.el6ev.noarch:
204 template, 30 VMs:
Move from Templates to VMs tab took 2 seconds.
Move from VMs tab to Templates tab took 1 sec.

Comment 3 Zac Dover 2014-04-03 02:26:49 UTC
This bug is currently attached to errata RHBA-2014:17286. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.

Comment 5 errata-xmlrpc 2014-04-09 17:56:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0384.html


Note You need to log in before you can comment on or make changes to this bug.