Bug 107030 - release notes ACPI discussion incorrect / unclear
release notes ACPI discussion incorrect / unclear
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 10:57 EDT by Chris Ricker
Modified: 2014-03-16 22:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-19 08:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-10-14 10:57:15 EDT
<CC'ed Tammy Fox on this as a start towards getting it routed to the right
person. Tammy, there doesn't seem to be any category for entering Fedora
documentation bugs -- all the old components like rhl-release-notes and such are
gone, and I don't see any replacements. http://fedora.redhat.com/projects/docs/
makes nice noises about filing bugs in Bugzilla, but doesn't actually tell how
to do so. It references some mysterious docs-project component, which doesn't
seem to exist anywhere that I can find....>

The Fedora Core release notes need updating / clarification regarding ACPI
support in the Fedora Core kernels. Currently, they say:

"The Fedora Core 0.95 kernel includes support for ACPI (Advanced Configuration
and Power Interface). By default, ACPI support is disabled; it can be enabled by
using the following boot-time option:

acpi=on

When enabled, ACPI is used for device enumeration, but not for sleeping or
reducing power consumption."

This is wrong. My understanding is that ACPI is always used for device
enumeration, but that it's not by default used for power management and such.
However, when enabled with acpi=on, ACPI power consumption management is also
enabled.
Comment 1 Bill Nottingham 2003-10-14 11:02:28 EDT
Power consumption is done by the base modules some. Sleep/suspend is almost
certainly guaranteed *not* to work, AFAIK. Dave - comments?
Comment 2 Tammy Fox 2003-10-14 11:17:42 EDT
I requested the extra Fedora bugzilla components a while back. I'll check into
it and make sure they are added.
Comment 3 Chris Ricker 2003-10-14 12:07:22 EDT
With acpi=on, /lib/modules/$(uname -r)/kernel/drivers/acpi/* gets loaded, and
you get some of the basic power management stuff. The original statement in the
release notes, OTOH, suggested to me that I'd still have to recompile even to
get very basic power management things like battery state reporting (as was the
case in RHL 9), and that's not true....

Along the same lines, the fedora core kernel appears to have support for the cpu
throttling stuff (speedstep / powernow / longhaul / whatever other marketing
term). With acpi=on, my mobile athlon says

powernow: AMD K7 CPU detected.
powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
...
powernow: Minimum speed 1064 MHz. Maximum speed 1795 MHz.

On the 2.6 kernels, there are nobs in sysfs for controlling this from userspace.
If there are equivalents for the 2.4 port (and there may not be -- I haven't
found any, and don't see much in the code to suggest there should be),
mentioning them in this section of the release notes would also be helpful
Comment 4 Dave Jones 2003-10-14 13:14:42 EDT
The powernow etc stuff is from cpufreq, nothing to do with ACPI at all.
You can control it with /proc/cpufreq
The docs are in the kernel packages Documentation/cpu-freq/ directory.
Comment 5 Chris Ricker 2003-10-14 14:10:01 EDT
You're right that cpufreq isn't ACPI, but it is power-management related. The
current docs for it say nothing applicable about how to actually use it. If you
actually read through them, you'll find that they only provide reference for the
2.6 (sysfs) commands. For the old interfaces -- /proc/cpuinfo (which does work
with the Fedora kernel) and /proc/sys/cpu/* (which doesn't work, except as a
read-only info source, with the Fedora kernel) -- they only say:

"Depending on your kernel configuration, you might find the following 
cpufreq-related files:
/proc/cpufreq
/proc/sys/cpu/*/speed
/proc/sys/cpu/*/speed-min
/proc/sys/cpu/*/speed-max

These are files for deprecated interfaces to cpufreq, which offer far
less functionality. Because of this, these interfaces aren't described
here."

Since this is a new feature in the Fedora kernel, and since the in-kernel
documentation is incomplete / unusable, it'd be nice if the release notes added
a paragraph covering echoing values to /proc/cpufreq to select rates, since at
least that part works even if there aren't true equivalents to all the sysfs
nobs....

The overall problem here with the release notes is that the current wording
regarding ACPI makes people think that the situation for those of us with newish
laptops is what it was with RHL 9 -- that you had to roll your own kernel with
ACPI support just to use the machine. The reality is different from that --
between acpi=on and cpufreq, I can actually get over 2 hours out of a single
battery on some of my AMD laptops and can functionally work while keeping an eye
on battery state, knowing when to shutdown, etc., with the stock kernel.
Comment 6 Ed Bailey 2003-10-19 08:03:41 EDT
Ok, I've updated the entry on acpi, and have added a new entry describing
/proc/cpufreq.  You'll see these updates reflected in the next release in early
November.  Thanks for your feedback!

Note You need to log in before you can comment on or make changes to this bug.