This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1070375 - (JON3-55) rhq:url-archive, rhq:archive should support destinationFile/destinationDir
rhq:url-archive, rhq:archive should support destinationFile/destinationDir
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.3.0
Unspecified Unspecified
medium Severity medium
: DR01
: JON 3.3.0
Assigned To: Jay Shaughnessy
Sunil Kondkar
:
Depends On: 1097321 665508
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-26 11:56 EST by Heiko W. Rupp
Modified: 2015-02-09 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 665508
Environment:
Last Closed: 2014-12-11 09:01:17 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JON3-55 Major Closed rhq:url-archive and rhq:archive should support destination attribute [PRODMGT-652] 2015-11-06 09:29 EST

  None (edit)
Description Heiko W. Rupp 2014-02-26 11:56:59 EST
+++ This bug was initially created as a clone of Bug #665508 +++

rhq:file and rhq:url-file each support the ability to indicate where the file should be copied on the destination machine.

rhq:archive and rhq:url-archive does not support those attributes. However, it would be nice to be able to tell where you want the archive to be stored. Note this probably only makes sense when exploded="false" since the zip file doesn't exist if its exploded.

<rhq:archive name="test.zip" exploded="false" destinationDir="subdir" ...

would mean the test.zip would get copied in ${rhq.deploy.dir}/subdir.

<rhq:url-archive url="http://server/files/test.zip" exploded="false" destinationDir="subdir" ...

would mean the test.zip would be downloaded from that URL and stored in ${rhq.deploy.dir}/subdir. Today, you have no choice but to have the downloaded file stored directly in ${rhq.deploy.dir}.
Comment 1 Jay Shaughnessy 2014-04-25 15:37:22 EDT
After some discussion decided that only the "destinationDir" attribute should be supported and not to support renaming archives.  Also, currently supporting this only when exploded=false.  Wiki updated: 

 https://docs.jboss.org/author/display/RHQ/Ant+Bundles#AntBundles-rhq%3Aarchive


master commit e26efc5c109e10da6418defa48b565c9b0c6097c
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Apr 25 15:34:22 2014 -0400

 Add "destinationDir" attribute for the archive targets.  Note that it can only
 be used in conjunction with "exploded=false".
Comment 2 JBoss JIRA Server 2014-05-05 04:09:33 EDT
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-55 to Resolved
Comment 3 JBoss JIRA Server 2014-05-07 10:00:39 EDT
Larry O'Leary <loleary@redhat.com> updated the status of jira JON3-55 to Reopened
Comment 9 Jay Shaughnessy 2014-05-15 15:23:32 EDT
master commit 007e6bdd575abd48681d6c321d6edbc878c29b52
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Thu May 15 15:21:15 2014 -0400

- Add support for exploded archives. So, the new destinationDir attribute
  can be used with exploded=true|false.

Also,
- Fix FileUtilTest.normalizePath() and .stripDriveLetter() to normalize
  the Windows drive letter by ensuring upcase.
Comment 10 JBoss JIRA Server 2014-05-21 12:09:14 EDT
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-55 to Resolved
Comment 11 Simeon Pinder 2014-07-31 11:52:02 EDT
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993
Comment 12 Sunil Kondkar 2014-08-14 09:34:26 EDT
Verified on Version : 3.3.0.DR01 Build Number : 6468454:dda0a47

TCMS execution run on linux and Windows:
https://tcms.engineering.redhat.com/run/167387/
https://tcms.engineering.redhat.com/run/167388/
Comment 13 Jared MORGAN 2014-10-27 20:35:35 EDT
JON 3-55 captures this release note work.
Comment 14 JBoss JIRA Server 2015-02-09 17:25:51 EST
Larry O'Leary <loleary@redhat.com> updated the status of jira JON3-55 to Closed

Note You need to log in before you can comment on or make changes to this bug.